[packages] mpd: update to 0.16.1 and refresh patches
authorloswillios <loswillios@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Mar 2011 16:57:22 +0000 (16:57 +0000)
committerloswillios <loswillios@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Mar 2011 16:57:22 +0000 (16:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26014 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/mpd/Makefile
sound/mpd/patches/100-compile-fixes.patch

index b86f867..7873bb7 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
-PKG_VERSION:=0.15.8
-PKG_RELEASE:=6
+PKG_VERSION:=0.16.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/musicpd
-PKG_MD5SUM:=824e1ce46c0f468865d9e5e403cdaf5d
+PKG_MD5SUM:=4d07459125ab0154c5b4fe364331498a
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
@@ -74,7 +74,6 @@ CONFIGURE_ARGS += \
        --enable-curl \
        --disable-oss \
        --with-zeroconf=no \
-       --disable-libOggFLACtest \
        --disable-test \
        --with-tremor=yes \
        --with-faad="$(STAGING_DIR)/usr" \
index 775bdc9..cd05159 100644 (file)
@@ -1,8 +1,8 @@
-Index: mpd-0.15.8/configure
+Index: mpd-0.16.1/configure
 ===================================================================
---- mpd-0.15.8.orig/configure  2010-11-04 00:14:37.187000000 +0100
-+++ mpd-0.15.8/configure       2010-11-04 00:15:00.156000001 +0100
-@@ -9191,6 +9191,7 @@
+--- mpd-0.16.1.orig/configure  2011-01-10 02:58:36.000000000 +0100
++++ mpd-0.16.1/configure       2011-03-10 13:01:31.000000000 +0100
+@@ -8718,6 +8718,7 @@
  # Check whether --with-faad was given.
  if test "${with_faad+set}" = set; then :
    withval=$with_faad;
@@ -10,18 +10,18 @@ Index: mpd-0.15.8/configure
  else
    faad_prefix=""
  fi
-Index: mpd-0.15.8/src/input/file_input_plugin.c
+Index: mpd-0.16.1/src/input/file_input_plugin.c
 ===================================================================
---- mpd-0.15.8.orig/src/input/file_input_plugin.c      2010-11-04 00:15:41.467000002 +0100
-+++ mpd-0.15.8/src/input/file_input_plugin.c   2010-11-04 00:15:49.194999211 +0100
-@@ -65,10 +65,6 @@
-       is->size = st.st_size;
+--- mpd-0.16.1.orig/src/input/file_input_plugin.c      2011-01-10 02:58:08.000000000 +0100
++++ mpd-0.16.1/src/input/file_input_plugin.c   2011-03-10 13:02:15.000000000 +0100
+@@ -79,10 +79,6 @@
+               return false;
+       }
  
 -#ifdef POSIX_FADV_SEQUENTIAL
--      posix_fadvise(fd, (off_t)0, is->size, POSIX_FADV_SEQUENTIAL);
+-      posix_fadvise(fd, (off_t)0, st.st_size, POSIX_FADV_SEQUENTIAL);
 -#endif
 -
-       is->plugin = &input_plugin_file;
-       is->data = GINT_TO_POINTER(fd);
-       is->ready = true;
+       fis = g_new(struct file_input_stream, 1);
+       input_stream_init(&fis->base, &input_plugin_file, filename);