ntripcaster: move to github
authornunojpg <nunojpg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 16 Sep 2014 00:59:42 +0000 (00:59 +0000)
committernunojpg <nunojpg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 16 Sep 2014 00:59:42 +0000 (00:59 +0000)
Signed-off-by: Nuno Goncalves <nunojpg@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@42564 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ntripcaster/Makefile [deleted file]

diff --git a/net/ntripcaster/Makefile b/net/ntripcaster/Makefile
deleted file mode 100644 (file)
index 27e1d37..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-#
-# Copyright (C) 2011 segal.ubi.pt
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ntripcaster
-PKG_VERSION:=0.1.5
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).zip
-PKG_SOURCE_URL:=http://igs.bkg.bund.de/root_ftp/NTRIP/software/
-PKG_MD5SUM:=8c85a6c31d8c5cdf2638fe103207a1fd
-
-PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/ntripcaster
-  SECTION:=net
-  CATEGORY:=Network
-  SUBMENU:=NTRIP
-  TITLE:=Standard Ntrip Broadcaster
-  URL:=http://igs.bkg.bund.de/ntrip/download
-  DEPENDS:=+libpthread
-endef
-
-define Package/ntripcaster/description
-  BKG Standard Ntrip Broadcaster
-endef
-
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       unzip $(DL_DIR)/$(PKG_SOURCE) -d $(PKG_BUILD_DIR)
-       mv $(PKG_BUILD_DIR)/$(PKG_NAME)$(PKG_VERSION)/* $(PKG_BUILD_DIR)
-       chmod +x $(PKG_BUILD_DIR)/configure
-endef
-
-define Package/ntripcaster/install
-       $(INSTALL_DIR) $(1)/usr/local/ntripcaster/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ntripcaster $(1)/usr/local/ntripcaster/bin/
-       $(INSTALL_DIR) $(1)/usr/local/ntripcaster/conf
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/conf/ntripcaster.conf.dist $(1)/usr/local/ntripcaster/conf/
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/conf/sourcetable.dat.dist $(1)/usr/local/ntripcaster/conf/
-endef
-
-$(eval $(call BuildPackage,ntripcaster))