packages/ahcpd: use new service functions
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:49:13 +0000 (23:49 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:49:13 +0000 (23:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28922 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/ahcpd/Makefile
ipv6/ahcpd/files/ahcpd.init

index 19beb30..a29e2b0 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ahcpd
 PKG_VERSION:=0.52
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
index bd1ecc9..6654b00 100644 (file)
@@ -1,7 +1,10 @@
 #!/bin/sh /etc/rc.common
+# Copyright (C) 2007-2011 OpenWrt.org
 
 START=71
-PID_F="/var/run/ahcpd.pid"
+
+SERVICE_USE_PID=1
+
 EXTRA_COMMANDS="status"
 EXTRA_HELP="        status Print ahcpd's status to the log file."
 
@@ -94,13 +97,13 @@ start() {
        config_foreach ahcp_config ahcpd
        config_foreach ahcp_server ahcpd
        [ -z "$interfaces" ] && return 0
-       eval "/usr/sbin/ahcpd -D -I $PID_F $args $interfaces"
+       service_start /usr/sbin/ahcpd -D $args $interfaces
 }
 
 stop() {
-       service_kill "ahcpd" "$PID_F"
+       service_stop /usr/sbin/ahcpd
 }
 
 status() {
-       [ -f $PID_F ] && kill -USR1 $(cat $PID_F)
+       SERVICE_SIG="USR1" service_signal /usr/sbin/ahcpd
 }