sysstat: moved to github
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Jul 2015 19:30:47 +0000 (19:30 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Jul 2015 19:30:47 +0000 (19:30 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@46319 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/sysstat/Makefile [deleted file]
utils/sysstat/files/config [deleted file]
utils/sysstat/files/sysstat.init [deleted file]

diff --git a/utils/sysstat/Makefile b/utils/sysstat/Makefile
deleted file mode 100644 (file)
index 4be0bb1..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# Copyright (C) 2008-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=sysstat
-PKG_VERSION:=9.0.6
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://pagesperso-orange.fr/sebastien.godard
-PKG_MD5SUM:=e069daf192d259de905d7f8cdd85dc4e
-
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/sysstat
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=Sysstat performance monitoring tools
-  URL:=http://pagesperso-orange.fr/sebastien.godard/index.html
-endef
-
-define Package/sysstat/description
-  The sysstat utilities are a collection of performance monitoring tools for
-  Linux. These include sar, sadf, mpstat, iostat, pidstat and sa tools.
-endef
-
-define Package/sysstat/conffiles
-/etc/sysstat/sysstat.ioconf
-/etc/sysstat/config
-endef
-
-CONFIGURE_VARS+= \
-       sa_lib_dir="/usr/lib/sysstat" \
-       sa_dir="/var/log/sysstat" \
-       conf_dir="/etc/sysstat" \
-
-CONFIGURE_ARGS+= \
-       --disable-documentation \
-
-define Package/sysstat/install
-       $(INSTALL_DIR) $(1)/usr/lib/sysstat
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/sysstat/{sadc,sa1,sa2} $(1)/usr/lib/sysstat/
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{sar,sadf,iostat,mpstat,pidstat} $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/etc/sysstat
-       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/sysstat/sysstat.ioconf $(1)/etc/sysstat/
-       $(INSTALL_CONF) ./files/config $(1)/etc/sysstat/config
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/sysstat.init $(1)/etc/init.d/sysstat
-endef
-
-$(eval $(call BuildPackage,sysstat))
diff --git a/utils/sysstat/files/config b/utils/sysstat/files/config
deleted file mode 100644 (file)
index 2d2721a..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-# How long to keep log files (days), maximum is a month
-# Used by sa2(8) script
-HISTORY=3
-
diff --git a/utils/sysstat/files/sysstat.init b/utils/sysstat/files/sysstat.init
deleted file mode 100755 (executable)
index 02039d5..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-# The init file runs the sadc command in order to write
-# the "LINUX RESTART" mark to the daily data file
-
-START=99
-
-start() {
-       mkdir -p /var/log/sysstat
-       /usr/lib/sysstat/sadc -S DISK -F -L -
-}
-