make use of the new PKG_HOST_ONLY variable in boost-jam
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Mar 2009 02:39:07 +0000 (02:39 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Mar 2009 02:39:07 +0000 (02:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14908 3c298f89-4303-0410-b956-a3cf2f4a3e73

devel/boost-jam/Makefile

index 98137b3..e9a1376 100644 (file)
@@ -14,8 +14,7 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/boost
-
-BUILDONLY:=1
+PKG_HOST_ONLY:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
@@ -24,12 +23,10 @@ define Package/boost-jam
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=Boost JAM
+  BUILDONLY:=1
   URL:=http://www.boost.org
 endef
 
-define Build/DefaultTargets
-endef
-
 define Host/Compile
        # bjam does not provide a configure-script nor a Makefile
        ( cd $(HOST_BUILD_DIR) ; ./build.sh gcc )