[packages] fix mocp dependencies
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jun 2012 11:58:43 +0000 (11:58 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jun 2012 11:58:43 +0000 (11:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32399 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/mocp/Makefile

index c343776..8cb333c 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/nls.mk
 define Package/moc
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-utils +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg
+  DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-utils +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg +libltdl
   TITLE:=Music On Console
   URL:=http://moc.daper.net/
 endef
@@ -39,6 +39,12 @@ define Build/Configure
                --enable-shared \
                --disable-static \
                --disable-debug \
+               --without-speex \
+               --without-samplerate \
+               --without-curl \
+               --without-flac \
+               --without-musepack \
+               --without-rcc \
        )
 endef