[packages] Introduce php5-pecl-apc package
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Jan 2013 15:27:44 +0000 (15:27 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Jan 2013 15:27:44 +0000 (15:27 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35273 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/php5-pecl-apc/Makefile [new file with mode: 0644]

diff --git a/lang/php5-pecl-apc/Makefile b/lang/php5-pecl-apc/Makefile
new file mode 100644 (file)
index 0000000..b27dd40
--- /dev/null
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PECL_NAME:=APC
+PECL_LONGNAME:=Alternative PHP Cache
+
+PKG_VERSION:=3.1.11
+PKG_RELEASE:=1
+PKG_MD5SUM:=199b69ed1423aa869acafff485ef5f06
+
+PKG_NAME:=php5-pecl-apc
+PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://pecl.php.net/get/
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PECL_NAME)-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+include ../php5/pecl.mk
+
+CONFIGURE_ARGS+= \
+       --enable-apc=shared \
+       --disable-apc-mmap \
+
+$(eval $(call PECLPackage,apc,$(PECL_LONGNAME),+librt))
+$(eval $(call BuildPackage,$(PKG_NAME)))