privoxy: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Dec 2014 19:40:57 +0000 (19:40 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Dec 2014 19:40:57 +0000 (19:40 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@43585 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/privoxy/Makefile [deleted file]
net/privoxy/files/privoxy.config [deleted file]
net/privoxy/files/privoxy.init [deleted file]

diff --git a/net/privoxy/Makefile b/net/privoxy/Makefile
deleted file mode 100644 (file)
index 7257d1f..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-#
-# Copyright (C) 2006-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=privoxy
-PKG_VERSION:=3.0.21
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
-PKG_SOURCE_URL:=@SF/ijbswa
-PKG_MD5SUM:=79558f2545cfcf9731f7de611646d837
-
-PKG_LICENSE:=GPLv2
-PKG_LICENSE_FILES:=LICENSE
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/privoxy
-  SECTION:=net
-  CATEGORY:=Network
-  SUBMENU:=Web Servers/Proxies
-  DEPENDS:=+libpcre +libpthread +zlib
-  TITLE:=web proxy with advanced filtering capabilities
-  URL:=http://www.privoxy.org/
-endef
-
-define Package/privoxy/description
-       Privoxy is a web proxy with advanced filtering capabilities for
-       protecting privacy, modifying web page content, managing cookies,
-       controlling access, and removing ads, banners, pop-ups and other
-       obnoxious Internet junk. Privoxy has a very flexible configuration
-       and can be customized to suit individual needs and tastes. Privoxy
-       has application for both stand-alone systems and multi-user networks.
-endef
-
-CONFIGURE_ARGS += \
-       --sysconfdir=/etc/privoxy \
-
-MAKE_FLAGS :=
-
-define Package/privoxy/conffiles
-/etc/privoxy/config
-endef
-
-define Package/privoxy/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/privoxy
-       $(CP) $(PKG_INSTALL_DIR)/etc/privoxy/* $(1)/etc/privoxy/
-       $(INSTALL_CONF) ./files/privoxy.config $(1)/etc/privoxy/config
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/privoxy.init $(1)/etc/init.d/privoxy
-endef
-
-$(eval $(call BuildPackage,privoxy))
diff --git a/net/privoxy/files/privoxy.config b/net/privoxy/files/privoxy.config
deleted file mode 100644 (file)
index 7f0b8af..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-confdir /etc/privoxy
-logdir /var/log
-filterfile default.filter
-logfile privoxy
-actionsfile match-all.action # Actions that are applied to all sites and maybe overruled later on.
-actionsfile default.action   # Main actions file
-#actionsfile user.action      # User customizations
-listen-address  127.0.0.1:8118
-toggle  1
-enable-remote-toggle  1
-enable-remote-http-toggle  0
-enable-edit-actions 1
-enforce-blocks 0
-buffer-limit 4096
-forwarded-connect-retries  0
-accept-intercepted-requests 0
-allow-cgi-request-crunching 0
-split-large-forms 0
-keep-alive-timeout 300
-socket-timeout 300
-permit-access  192.168.1.0/24
-debug   1    # show each GET/POST/CONNECT request
-debug   4096 # Startup banner and warnings
-debug   8192 # Errors - *we highly recommended enabling this*
-#admin-address privoxy-admin@example.com
-#proxy-info-url http://www.example.com/proxy-service.html
-
diff --git a/net/privoxy/files/privoxy.init b/net/privoxy/files/privoxy.init
deleted file mode 100644 (file)
index 78c29b4..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006-2011 OpenWrt.org
-
-START=80
-STOP=80
-
-SERVICE_USE_PID=1
-
-start() {
-       service_start /usr/sbin/privoxy --pidfile /var/run/privoxy.pid \
-                                       /etc/privoxy/config
-}
-
-stop() {
-       service_stop /usr/sbin/privoxy
-}