alpine: fix build on Archlinux
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Jan 2014 13:30:15 +0000 (13:30 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Jan 2014 13:30:15 +0000 (13:30 +0000)
alpine adds a wrong path during configure (-L/usr/lib)
this leads to build fail on Archlinux
...
checking for setupterm in -lncurses... no
...
"configure: error: Terminfo/termcap not found"

since Debian uses a different path for "host libs" it fails to load wrong libs
and finds the right ncurses lib in the next (correct) path

The wrong path is injected by the SSL test
thx jow for finding it

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39423 3c298f89-4303-0410-b956-a3cf2f4a3e73

mail/alpine/Makefile

index 8a31525..a46d57e 100644 (file)
@@ -37,6 +37,7 @@ endef
 
 CONFIGURE_ARGS += \
        --with-ssl-include-dir=$(STAGING_DIR)/usr/include/openssl/. \
+       --with-ssl-lib-dir=$(STAGING_DIR)/usr/lib \
        --without-tcl \
        --without-ldap \
        --without-krb5 \