[package] set PKGARCH to all for packages containing only arch-neutral files (#5572)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 24 Jul 2009 12:07:24 +0000 (12:07 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 24 Jul 2009 12:07:24 +0000 (12:07 +0000)
Signed-off-by: Malte S. Stretz <mss@apache.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16965 3c298f89-4303-0410-b956-a3cf2f4a3e73

devel/build-essential/Makefile
ipv6/6scripts/Makefile
lang/php-pear-xmlrpc/Makefile
net/ddns-scripts/Makefile
net/shorewall-common/Makefile
net/speedtouch-usb-firmware/Makefile
net/wshaper/Makefile
utils/bash-completion/Makefile
utils/dir300-flash/Makefile

index 446440a..f22611d 100644 (file)
@@ -19,6 +19,7 @@ define Package/build-essential
   CATEGORY:=Development
   TITLE:=Build essentials 
   DEPENDS=+gcc +make +binutils +patch +diffutils @NO_STRIP
+  PKGARCH:=all
 endef
 
 define Build/Compile
index 1174f4b..f4e54fe 100644 (file)
@@ -18,6 +18,7 @@ define Package/6scripts
   CATEGORY:=IPv6
   DEPENDS:=+kmod-ipv6
   TITLE:=IPv6 scripts
+  PKGARCH:=all
 endef
 
 define Package/6scripts/description
index 81eae6a..094a9bb 100644 (file)
@@ -26,6 +26,7 @@ define Package/php-pear-xmlrpc
   TITLE:=PEAR XML-RPC module
   URL:=http://pear.php.net/
   DEPENDS:=php-pear
+  PKGARCH:=all
 endef
 
 define Build/Configure
index 8b51b74..97c3d96 100644 (file)
@@ -12,6 +12,7 @@ define Package/ddns-scripts
        SECTION:=net
        CATEGORY:=Network
        TITLE:=Dynamic DNS Scripts
+       PKGARCH:=all
 endef
 
 define Package/ddns-scripts/description
index 9cb08fa..702f56d 100644 (file)
@@ -24,6 +24,7 @@ define Package/shorewall-common
   TITLE:=Shorewall
   URL:=http://www.shorewall.net/
   SUBMENU:=firewall
+  PKGARCH:=all
 endef
 
 define Package/shorewall-common/description
index 4e3fe0a..c55b005 100644 (file)
@@ -25,6 +25,7 @@ define Package/speedtouch-usb-firmware
   CATEGORY:=Network
   TITLE:=SpeedTouch 330 ADSL USB firmware
   DEPENDS:=+kmod-usb-atm +kmod-usb-atm-speedtouch @LINUX_2_6
+  PKGARCH:=all
 endef
 
 define Package/speedtouch-usb-firmware/description
index 9366af2..987086b 100644 (file)
@@ -20,6 +20,7 @@ define Package/wshaper
   DEPENDS:=+kmod-sched +tc
   TITLE:=wshaper
   URL:=http://lartc.org/wondershaper/
+  PKGARCH:=all
 endef
 
 define Package/wshaper/description
index 95e91d9..fc4ed53 100644 (file)
@@ -25,6 +25,7 @@ define Package/bash-completion
   TITLE:=bash completion scripts
   DEPENDS:=+libncurses +bash
   URL:=http://www.caliban.org/bash/
+  PKGARCH:=all
 endef
 
 define Package/bash-completion/description
index a5146f9..c271212 100644 (file)
@@ -23,6 +23,7 @@ define Package/dir300-flash
   CATEGORY:=Utilities
   TITLE:=Flashes a custom firmware on the DIR-300 wireless router
   URL:=http://x-alina.freifunk-potsdam.de/
+  PKGARCH:=all
 endef
 
 define Download/ap61.ram