[net] Monitoring: Finally collected a Nagios programs under Monitoring submenu.
[packages.git] / net / nrpe / Makefile
index c355a7d..06ca352 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,29 +9,31 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nrpe
-PKG_VERSION:=2.8.1
+PKG_VERSION:=2.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagios
-PKG_MD5SUM:=
+PKG_MD5SUM:=b2d75e2962f1e3151ef58794d60c9e97
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/nrpe
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Monitoring
   DEPENDS:=+libopenssl
   TITLE:=Daemon to execute Nagios check commands on remote hosts
   URL:=http://www.nagios.org/download
 endef
 
 define Package/nrpe/description
- NOTE: several assumptions are made:
- 1) As openssl is used to generate some stuff during "configure" it is 
- assumed that openssl is installed on compiling PC in its default
- location (i.e. accessible as /usr/bin/openssl).
- 2) "nagios" user and group should exist on your openwrt installation.
+       The NRPE addon is designed to allow you to execute Nagios plugins on
+       remote Linux/Unix machines.  The main reason for doing this is to allow
+       Nagios to monitor "local" resources (like CPU load, memory usage, etc.)
+       on remote machines.  Since these public resources are not usually
+       exposed to external machines, an agent like NRPE must be installed on
+       the remote Linux/Unix machines.
 endef
 
 define Package/nrpe/postinst
@@ -72,6 +74,7 @@ endef
 
 CONFIGURE_ARGS += \
        --with-ssl="$(STAGING_DIR)/usr" \
+       --with-ssl-lib="$(STAGING_DIR)/usr/lib"
 
 define Package/nrpe/install
        $(INSTALL_DIR) $(1)/usr/sbin
@@ -82,9 +85,9 @@ define Package/nrpe/install
        $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
-$(eval $(call BuildPackage,nrpe))
-
 $(eval $(call RequireCommand,openssl, \
        $(PKG_NAME) requires openssl installed on the host-system. \
 ))
 
+$(eval $(call BuildPackage,nrpe))
+