remove PKG_CAT from packages
[packages.git] / multimedia / motion / Makefile
index a29d90a..220c760 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
-PKG_VERSION:=3.2.6
+PKG_VERSION:=20070331-051001
 PKG_RELEASE:=1
-PKG_MD5SUM:=71e6bd13fcca70372e9b7c7806d62b30
 
-PKG_SOURCE_URL:=@SF/motion
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
+               @SF/motion
+PKG_MD5SUM:=16e58186022dfee1c0dcaf03cf5393e5
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -27,29 +27,34 @@ define Package/motion
   CATEGORY:=Multimedia
   DEPENDS:=+libjpeg
   TITLE:=webcam motion sensing and logging
-  DESCRIPTION:=Motion is a software motion detector
   URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
 endef
 
+define Package/motion/conffiles
+/etc/motion.conf
+endef
+
 define Build/Configure
-$(call Build/Configure/Default,--without-ffmpeg \
-                       --without-jpeg-mmx \
-                       --without-mysql \
-                       --without-pgsql \
-)
+       $(call Build/Configure/Default, \
+               --without-ffmpeg \
+               --without-jpeg-mmx \
+               --without-mysql \
+               --without-pgsql \
+       )
 endef
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/motion/install  
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc
+       $(CP) $(PKG_INSTALL_DIR)/etc/motion-dist.conf $(1)/etc/motion.conf
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(1)/usr/bin/
+
 endef
 
 $(eval $(call BuildPackage,motion))