[packages] Use default templates instead of custom reimplementations where applicable
[packages.git] / libs / popt / Makefile
index 4f22390..34e4b25 100644 (file)
@@ -15,8 +15,12 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
 PKG_MD5SUM:=5988e7aeb0ae4dac8d83561265984cc9
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS += $(FPIC)
+
 define Package/libpopt
   SECTION:=libs
   CATEGORY:=Libraries
@@ -31,14 +35,6 @@ define Build/Configure
        )
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/popt.h $(1)/usr/include/