fix up downloading in python packages
[packages.git] / lang / twisted / Makefile
index 799e826..6cab302 100644 (file)
@@ -21,8 +21,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/twisted/default