[curl]: enable compile against axTLS and CyaSSL
[packages.git] / ipv6 / ahcpd / Makefile
index a273e44..95af352 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ahcpd
-PKG_VERSION:=0.50
-PKG_RELEASE:=3
+PKG_VERSION:=0.53
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=627ec199784c60e5250651f82511fff2
+PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
+PKG_MD5SUM:=a1a610bf20965aa522cd766bf3d5829a
+
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ahcpd
-  SECTION:=ipv6
-  CATEGORY:=IPv6
+  SECTION:=net
+  CATEGORY:=Network
   TITLE:=Ad-Hoc Configuration Protocol daemon
-  URL:=http://www.pps.jussieu.fr/~jch/software/ahcp/
+  URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/ahcp/
+  MAINTAINER:=Gabriel Kerneis <kerneis@pps.univ-paris-diderot.fr>
   DEPENDS:=+kmod-ipv6 +ip +librt
 endef
 
@@ -32,32 +34,18 @@ define Package/ahcpd/description
  also be used on wired networks.
 endef
 
-define Build/Configure
-       ( cd $(PKG_BUILD_DIR); \
-               $(SED) 's,/usr/local/bin/,/usr/lib/ahcp/,g' ahcpd.c ; \
-               $(SED) 's,/usr/local/lib/ahcp/,/usr/lib/ahcp/,g' ahcp-config.sh ; \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               all
-endef
-
 define Package/ahcpd/conffiles
 /etc/config/ahcpd
 endef
 
 define Package/ahcpd/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_DIR) $(1)/usr/lib/ahcp
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ahcp-config.sh $(1)/usr/lib/ahcp/
+       $(INSTALL_DIR) $(1)/etc/ahcp
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ahcp-config.sh $(1)/etc/ahcp/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ahcpd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/ahcpd.config $(1)/etc/config/ahcpd
+       $(INSTALL_CONF) ./files/ahcpd.config $(1)/etc/config/ahcpd
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ahcpd.init $(1)/etc/init.d/ahcpd
 endef