[packages] Add missing md5sums
[packages.git] / devel / binutils / Makefile
index 318d387..98525cb 100644 (file)
@@ -10,9 +10,15 @@ PKG_NAME:=binutils
 PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
 #"))
 PKG_RELEASE:=2
+
 PKG_SOURCE_URL:=@GNU/binutils
 PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=
+
 PATCH_DIR:=$(TOPDIR)/toolchain/binutils/patches/$(PKG_VERSION)
+
+PKG_FIXUP:=libtool
+PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof binutils ld
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -42,6 +48,18 @@ define Build/Configure
                --disable-werror \
                --disable-nls \
        )
+       $(call Build/Compile/Default, \
+               configure-bfd \
+               configure-binutils \
+               configure-etc \
+               configure-gas \
+               configure-gprof \
+               configure-intl \
+               configure-ld \
+               configure-libiberty \
+               configure-opcodes \
+       )
+       $(MAKE) -C $(PKG_BUILD_DIR)/bfd/po Makefile
 endef
 
 define Build/InstallDev
@@ -55,6 +73,7 @@ define Build/InstallDev
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/include/* \
                $(1)/usr/include/
+       rm -f $(1)/usr/include/gdbm.h
 endef
 
 define Build/Compile