poco: moved to github
[packages.git] / admin / osiris / Makefile
index 917134a..d93689b 100644 (file)
@@ -1,63 +1,50 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=osiris
-PKG_VERSION:=4.2.1
-PKG_RELEASE:=1
+PKG_VERSION:=4.2.3
+PKG_RELEASE:=3
 
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://osiris.shmoo.com/data/
-PKG_MD5SUM:=11445f7d8dec737f0be89357f5c5bcae
-PKG_CAT:=zcat
+PKG_MD5SUM:=1951c7dc0fe729af9ffaf58910340d12
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=autoreconf
+PKG_LIBTOOL_PATHS:=src/db-4.2.52/build_unix
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/osirisd
   SECTION:=admin
   CATEGORY:=Administration
-  DEPENDS:=+libopenssl
+  DEPENDS:=+libopenssl +libpthread
   TITLE:=Host integrity monitoring system (scanning agent)
-  DESCRIPTION:=an Host Integrity Monitoring System (scanning agent)
-  URL:=http://www.hostintegrity.com/osiris
+  URL:=http://osiris.shmoo.com/
 endef
 
-define Build/Configure
-  $(call Build/Configure/Default, \
+CONFIGURE_ARGS += \
        --with-osiris-user=root \
        --with-root-dir=/var/lib/osiris \
        --with-readline=no, \
-       ac_cv_openssldir="$(STAGING_DIR)/usr" \
-       ac_cv_have_accrights_in_msghdr=no \
-       ac_cv_have_control_in_msghdr=yes \
-  )
-endef
+       ac_cv_openssldir="$(STAGING_DIR)/usr"
 
-define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
+MAKE_FLAGS += \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               INTERACTIVE=0 \
-               all install
-endef
+               INTERACTIVE=0
 
-define Package/osirisd/install 
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/osirisd.init $(1)/etc/init.d/osirisd
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/osirisd $(1)/usr/sbin/
+define Package/osirisd/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/osirisd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/osirisd.init $(1)/etc/init.d/osirisd
 endef
 
 $(eval $(call BuildPackage,osirisd))