poco: moved to github
[packages.git] / admin / nagios-plugins / Makefile
index 1d48e50..d5fa97e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nagios-plugins
 PKG_VERSION:=1.4.14
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagiosplug
@@ -18,6 +18,7 @@ PKG_MD5SUM:=a1835a48a777863ed2583de3c82446a9
 PKG_FIXUP:=patch-libtool
 PKG_INSTALL:=1
 
+include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 comma:= ,
@@ -25,7 +26,7 @@ comma:= ,
 define Package/nagios-plugins
   SECTION:=admin
   CATEGORY:=Administration
-  DEPENDS:=+uclibcxx +libpq +libopenssl
+  DEPENDS:=$(CXX_DEPENDS) +libpq +libopenssl +libradiusclient-ng +libopenldap
   TITLE:=plugins for Nagios checks
   URL:=http://nagiosplug.sourceforge.net/
 endef
@@ -35,10 +36,10 @@ CONFIGURE_ARGS += \
        --with-openssl="$(STAGING_DIR)/usr" \
        --with-ping-command="/bin/ping -w %d -c %d %s" \
        --with-ping6-command="/bin/ping6 -w %d -c %d %s" \
-       --with-ps-command="/bin/ps -Aopid" \
+       --with-ps-command="/bin/ps w" \
        --with-ps-cols="6" \
        --with-ps-format="%d %s %d %s %s %n" \
-       --with-ps-varlist="&procuid$(comma)&procpid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
+       --with-ps-varlist="&procpid$(comma)&procuid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
        --with-uptime-command="/usr/bin/uptime" \
        --with-ssh-command="/usr/bin/ssh" \
        --with-nslookup-command="/usr/bin/nslookup"