libsrtp: partially revert previous commit
authorJiri Slachta <slachta@cesnet.cz>
Sun, 10 Aug 2014 01:32:16 +0000 (03:32 +0200)
committerJiri Slachta <slachta@cesnet.cz>
Sun, 10 Aug 2014 01:32:16 +0000 (03:32 +0200)
Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
libs/libsrtp/Makefile

index 9118f4f..57ab82e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011-2012 OpenWrt.org
+# Copyright (C) 2014 OpenWrt.org
 # Copyright (C) 2011 Victor Seva <linuxmaniac@torreviejawireless.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -23,45 +23,18 @@ include $(INCLUDE_DIR)/package.mk
 TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += --disable-stdout --enable-syslog
 
-define Package/libsrtp/Default
+define Package/libsrtp
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=Secure Real-time Transport Protocol (SRTP)
+  TITLE:=Secure Real-time Transport Protocol (SRTP) library
   URL:=http://sourceforge.net/projects/srtp
   MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
 endef
 
-define Package/libsrtp/Default/description
-  Open-source implementation of the Secure Real-time Transport
-  Protocol (SRTP) originally authored by Cisco Systems, Inc.
-  It is available under a BSD-style license.
-endef
-
-define Package/libsrtp
-  $(call Package/libsrtp/Default)
-  TITLE+= library
-endef
-
 define Package/libsrtp/description
-  $(call Package/libsrtp/Default/description)
-
-  This package ONLY contains shared libraries. For development
-  libraries, please install libsrtp-dev package.
-
-endef
-
-define Package/libsrtp-dev
-  $(call Package/libsrtp/Default)
-  TITLE+= development library
-  DEPENDS:=+libsrtp
-endef
-
-define Package/libsrtp-dev/description
-  $(call Package/libsrtp/Default/description)
-
-  This package contains ONLY include files, static libraries, and
-  pkgconfig files.
-
+Open-source implementation of the Secure Real-time Transport
+Protocol (SRTP) originally authored by Cisco Systems, Inc.
+It is available under a BSD-style license.
 endef
 
 define Build/InstallDev
@@ -74,15 +47,8 @@ endef
 
 define Package/libsrtp/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.so* $(1)/usr/lib/
-endef
-
-
-define Package/libsrtp-dev/install
-       $(INSTALL_DIR) $(1)/usr/{include,lib}
-       $(CP) $(PKG_INSTALL_DIR)/usr/include $(1)/usr/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.a $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsrtp.so.* \
+               $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libsrtp))
-$(eval $(call BuildPackage,libsrtp-dev))