freeswitch: fix build when ccache is enabled
authorJohn Crispin <blogic@openwrt.org>
Thu, 17 Jul 2014 20:28:50 +0000 (21:28 +0100)
committerJohn Crispin <blogic@openwrt.org>
Tue, 2 Sep 2014 07:07:13 +0000 (09:07 +0200)
Signed-off-by: John Crispin <blogic@openwrt.org>
net/freeswitch/Makefile

index 0a1461c..52f05c4 100644 (file)
@@ -224,6 +224,11 @@ PKG_CONFIG_DEPENDS:= \
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
+ifneq ($(CONFIG_CCACHE),)
+TARGET_CC=$(TARGET_CC_NOCACHE)
+TARGET_CXX=$(TARGET_CXX_NOCACHE)
+endif
+
 
 define Package/$(PKG_NAME)/Default
   SECTION:=net