FreeSWITCH:
authorMazi Lo <openwrt.mazilo@recursor.net>
Sat, 16 Aug 2014 02:08:15 +0000 (22:08 -0400)
committerMazi Lo <openwrt.mazilo@recursor.net>
Sat, 16 Aug 2014 02:08:15 +0000 (22:08 -0400)
 1. Bump to FS GIT EHAD 5173471b06d88063ec7e2622c92c9674840ae4b1.
 2. Flag mod_yaml as BROKEN.
 3. Fine tune PKG_CONFIG_PATH to ${STAGING_DIR}/usr/lib/pkg-config .

Signed-off-by: Mazi Lo <openwrt.mazilo@recursor.net>
net/freeswitch/Config.in
net/freeswitch/Makefile
net/freeswitch/patches/0000010-configure_ac.patch

index 0c3032f..9a315dd 100644 (file)
@@ -2,7 +2,7 @@ menu "Configuration"
   depends on PACKAGE_freeswitch
 
   choice
-  depends on DEVEL
+    depends on DEVEL
     prompt "Git HEAD version to use"
     default FS_WITH_DEFAULT_HEAD
     help
index 8573ad7..0a1461c 100644 (file)
@@ -18,7 +18,7 @@ PKG_VERSION:=1.5.13b
 # The latest FS git hash in PKG_SOURCE_VERSION can be obtained from
 # http://fisheye.freeswitch.org
 #
-FS_WITH_DEFAULT_HEAD:=e3e84a7820954195e8311be783a3e0cf9c1ba2ad
+FS_WITH_DEFAULT_HEAD:=5173471b06d88063ec7e2622c92c9674840ae4b1
 PKG_SOURCE_URL:=https://stash.$(PKG_NAME).org/scm/fs/$(PKG_NAME).git
 PKG_SOURCE_VERSION:=$(if $(CONFIG_FS_WITH_LATEST_HEAD),$(shell git ls-remote $(PKG_SOURCE_URL) HEAD|cut -f1),$(FS_WITH_DEFAULT_HEAD))
 FS_WITH_DEFAULT_HEAD_SHORT:=$(shell echo $(FS_WITH_DEFAULT_HEAD)|cut -b -7)
@@ -238,7 +238,7 @@ endef
 define Package/$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   TITLE:=FreeSWITCH open source telephony platform ($(PKG_SOURCE_VERSION_SHORT))
-  DEPENDS:=+FS_WITH_CORE_LIBEDIT_SUPPORT:libedit +FS_WITH_OPENSSL:libopenssl +libcurl +libdb47 +libgdbm $(ICONV_DEPENDS) $(INTL_DEPENDS) +libjpeg +libncurses +libopenldap +libpcre +libpthread +librt +libspeex +libspeexdsp +FS_WITH_SQLITE3:libsqlite3 +FS_WITH_SRTP:libsrtp +SSP_SUPPORT:libssp +libstdcpp +libuuid
+  DEPENDS:=+FS_WITH_CORE_LIBEDIT_SUPPORT:libedit +FS_WITH_OPENSSL:libopenssl +libcurl +libdb47 +libgdbm $(ICONV_DEPENDS) $(INTL_DEPENDS) +libjpeg +libncurses +libopenldap +libpcre +libpthread +librt +libspeex +libspeexdsp +FS_WITH_SQLITE3:libsqlite3 +FS_WITH_SRTP:libsrtp +SSP_SUPPORT:libssp +libstdcpp +libuuid +PACKAGE_$(PKG_NAME)-mod-perl:perl
 endef
 
 
@@ -669,13 +669,13 @@ define Build/Prepare
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-sounds-moh-32KHz),$(call Prepare/sounds-moh-32KHz))
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-sounds-moh-48KHz),$(call Prepare/sounds-moh-48KHz))
 ifeq ($(CONFIG_FS_WITH_LOCAL_SOURCE),y)
-       (cd $(PKG_BUILD_DIR); $(if $(CONFIG_FS_WITH_LATEST_HEAD),if $(QUILT_CMD) top > /dev/null 2>&1; then $(QUILT_CMD) pop -a; fi; git pull; if $(QUILT_CMD) next > /dev/null 2>&1; then $(QUILT_CMD) push -a; fi))
+       (cd $(PKG_BUILD_DIR); $(if $(CONFIG_FS_WITH_LATEST_HEAD),if $(QUILT_CMD) top > /dev/null 2>&1; then $(QUILT_CMD) pop -a; fi; git pull;) if $(QUILT_CMD) next > /dev/null 2>&1; then $(QUILT_CMD) push -a; fi)
 endif
 endef
 
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); $(if $(CONFIG_FS_WITH_LATEST_HEAD),if $(QUILT_CMD) top > /dev/null 2>&1; then $(QUILT_CMD) pop -a; fi; git pull; if $(QUILT_CMD) next > /dev/null 2>&1; then $(QUILT_CMD) push -a; fi))
+       (cd $(PKG_BUILD_DIR); $(if $(CONFIG_FS_WITH_LATEST_HEAD),if $(QUILT_CMD) top > /dev/null 2>&1; then $(QUILT_CMD) pop -a; fi; git pull;) if $(QUILT_CMD) next > /dev/null 2>&1; then $(QUILT_CMD) push -a; fi)
        (cd $(PKG_BUILD_DIR); $(AM_TOOL_PATHS) ./bootstrap.sh)
        $(foreach m,$(FS_MOD_AVAILABLE),
                $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-$(m)),
@@ -1102,4 +1102,4 @@ $(eval $(call BuildPlugin,xml-ldap,LDAP-XML Gateway,vanilla,,,,+PACKAGE_$(PKG_NA
 $(eval $(call BuildPlugin,xml-rpc,XML-RPC Interface,vanilla,,,,))
 $(eval $(call BuildPlugin,xml-radius,Radius authentication and authorization,vanilla,,,,+freeradius-client @BROKEN)) # freeradius-client isn't yet supported by OpenWRT.
 $(eval $(call BuildPlugin,xml-scgi,SCGI XML Gateway,vanilla,,,,))
-$(eval $(call BuildPlugin,yaml,YAML langunage,vanilla,,,,+libyaml))
+$(eval $(call BuildPlugin,yaml,YAML langunage,vanilla,,,,+libyaml @BROKEN))
index f490b99..f9d3753 100644 (file)
  AC_CHECK_LIB(util, openpty, [AC_DEFINE(HAVE_OPENPTY, 1, [Define if you have openpty()])])
  
  AC_CHECK_MEMBERS([struct tm.tm_gmtoff],,,[
+@@ -1135,14 +1134,14 @@ case $host in
+        ;;
+ esac
+-if ! (test -x "$PKG_CONFIG" || test -x "$(which pkg-config)"); then
+-  AC_MSG_ERROR([You need to install pkg-config to configure FreeSWITCH.])
++if ! test -x "${STAGING_DIR}/../host/bin/pkg-config"; then
++  AC_MSG_ERROR([Missing tools/pkg-config package needed to configure FreeSWITCH.])
+ fi
+-# temporary workaround for Debian libldns-dev package bug
+-if test "$cross_compiling" != "yes" && test -f /usr/lib/pkg-config/libldns.pc; then
+-  path_push_unique PKG_CONFIG_PATH /usr/lib/pkg-config
+-fi
++#
++# Workaround for OpenWRT pkg-config
++#
++path_push_unique PKG_CONFIG_PATH ${STAGING_DIR}/usr/lib/pkg-config
+ module_enabled() {
+   grep -v -e "\#" -e "^\$" modules.conf | sed -e "s|^.*/||" | grep "^${1}\$" >/dev/null
+@@ -1163,7 +1162,7 @@ PKG_CHECK_MODULES([LDNS], [libldns >= 1.
+   AC_CHECK_LIB([ldns], [ldns_str2rdf_a], [LDNS_LIBS=-lldns])
+   AS_IF([test -z "$LDNS_LIBS"],[
+     if module_enabled mod_enum; then
+-      AC_MSG_ERROR([You need to either install libldns-dev or disable mod_enum in modules.conf])
++      AC_MSG_ERROR([You need to install libldns or disable mod_enum in modules.conf])
+     else
+       AC_MSG_RESULT([no]); AM_CONDITIONAL([HAVE_LDNS],[false])
+     fi],[
 @@ -1241,36 +1240,43 @@ AM_CONDITIONAL([HAVE_MYSQL],[test "$foun
  # perl checks
  #