FreeSWITCH:
authorMazi Lo <openwrt.mazilo@recursor.net>
Sun, 10 Aug 2014 15:43:25 +0000 (11:43 -0400)
committerMazi Lo <openwrt.mazilo@recursor.net>
Sun, 10 Aug 2014 15:43:25 +0000 (11:43 -0400)
  1. Fix no FS_WITH_SQLITE3 due to @DEVEL in Config.in
  2. Fix configure error due to no ldns package needed by mod_enum.

Signed-off-by: Mazi Lo <openwrt.mazilo@recursor.net>
net/freeswitch/Config.in
net/freeswitch/Makefile

index 6a3a533..6eaafad 100644 (file)
@@ -1,7 +1,8 @@
 menu "Configuration"
-  depends on PACKAGE_freeswitch && DEVEL
+  depends on PACKAGE_freeswitch
 
   choice
+  depends on DEVEL
     prompt "Git HEAD version to use"
     default FS_WITH_DEFAULT_HEAD
     help
index 6a79836..8573ad7 100644 (file)
@@ -677,7 +677,6 @@ endef
 define Build/Configure
        (cd $(PKG_BUILD_DIR); $(if $(CONFIG_FS_WITH_LATEST_HEAD),if $(QUILT_CMD) top > /dev/null 2>&1; then $(QUILT_CMD) pop -a; fi; git pull; if $(QUILT_CMD) next > /dev/null 2>&1; then $(QUILT_CMD) push -a; fi))
        (cd $(PKG_BUILD_DIR); $(AM_TOOL_PATHS) ./bootstrap.sh)
-       $(call Build/Configure/Default)
        $(foreach m,$(FS_MOD_AVAILABLE),
                $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-$(m)),
                        $(SED) 's|^[ #]*\([^#]*/mod_$(subst -,_,$(m))\)$$$$|\1|g' $(PKG_BUILD_DIR)/modules.conf
@@ -685,6 +684,7 @@ define Build/Configure
                        $(SED) 's|^\([^#]*/mod_$(subst -,_,$(m))\)$$$$|#\1|g' $(PKG_BUILD_DIR)/modules.conf
                )
        )
+       $(call Build/Configure/Default)
 endef