FreeSWITCH: Git HASH 66dafbde8ca0484141f044bcdf8132310742b443
authorMazi Lo <openwrt.mazilo@recursor.net>
Fri, 10 Oct 2014 14:19:31 +0000 (10:19 -0400)
committerMazi Lo <openwrt.mazilo@recursor.net>
Fri, 10 Oct 2014 14:19:31 +0000 (10:19 -0400)
1. Update MD5SUM on sounds-en-us-callie files.
2. Update patches.
3. Fix on spelling error.
4. Fix (minor) on LDFLAGS for perl.

Signed-off-by: Mazi Lo <openwrt.mazilo@recursor.net>
net/freeswitch/Makefile
net/freeswitch/patches/0000010-configure_ac.patch
net/freeswitch/patches/0000011-Makefile.am.patch
net/freeswitch/patches/1306000-src-mod-directories-mod_ldap-Makefile_am.patch

index b17435e..dd3e072 100644 (file)
@@ -18,7 +18,7 @@ PKG_VERSION:=1.5.15b
 # The latest FS git hash in PKG_SOURCE_VERSION can be obtained from
 # http://fisheye.freeswitch.org
 #
-FS_WITH_DEFAULT_HEAD:=f7210b2402488ec8f9be97cc79921fa605bbb7a4
+FS_WITH_DEFAULT_HEAD:=66dafbde8ca0484141f044bcdf8132310742b443
 PKG_SOURCE_URL:=https://stash.$(PKG_NAME).org/scm/fs/$(PKG_NAME).git
 PKG_SOURCE_VERSION:=$(if $(CONFIG_FS_WITH_LATEST_HEAD),$(shell git ls-remote $(PKG_SOURCE_URL) HEAD|cut -f1),$(FS_WITH_DEFAULT_HEAD))
 FS_WITH_DEFAULT_HEAD_SHORT:=$(shell echo $(FS_WITH_DEFAULT_HEAD)|cut -b -7)
@@ -495,19 +495,19 @@ endif
 
 
 ifneq ($(CONFIG_PACKAGE_$(PKG_NAME)-sounds-en-16KHz),)
- $(eval $(call Download/files,sounds-en-16KHz,$(PKG_NAME)-sounds-en-us-callie-16000-1.0.50.tar.gz,0c0bda571e61251a8b86121913543b36,,,))
+ $(eval $(call Download/files,sounds-en-16KHz,$(PKG_NAME)-sounds-en-us-callie-16000-1.0.50.tar.gz,261f42e310baa97cc4dcfdc51971aff8,,,))
        MAKE_INSTALL_TARGETS+= hd-sounds-install
 endif
 
 
 ifneq ($(CONFIG_PACKAGE_$(PKG_NAME)-sounds-en-32KHz),)
- $(eval $(call Download/files,sounds-en-32KHz,$(PKG_NAME)-sounds-en-us-callie-32000-1.0.50.tar.gz,42e5dd920ed7454eadcad71d80ee8900,,,))
+ $(eval $(call Download/files,sounds-en-32KHz,$(PKG_NAME)-sounds-en-us-callie-32000-1.0.50.tar.gz,f204512fadc49a3267ff4a5e899b77a5,,,))
        MAKE_INSTALL_TARGETS+= uhd-sounds-install
 endif
 
 
 ifneq ($(CONFIG_PACKAGE_$(PKG_NAME)-sounds-en-48KHz),)
- $(eval $(call Download/files,sounds-en-48KHz,$(PKG_NAME)-sounds-en-us-callie-48000-1.0.50.tar.gz,8776597979257d10009052df06251051,,,))
+ $(eval $(call Download/files,sounds-en-48KHz,$(PKG_NAME)-sounds-en-us-callie-48000-1.0.50.tar.gz,8622a77a5d6dcf5e47bdf30d6a33e27c,,,))
        MAKE_INSTALL_TARGETS+= cd-sounds-install
 endif
 
@@ -1095,4 +1095,4 @@ $(eval $(call BuildPlugin,xml-ldap,LDAP-XML Gateway,vanilla,,,,+PACKAGE_$(PKG_NA
 $(eval $(call BuildPlugin,xml-rpc,XML-RPC Interface,vanilla,,,,))
 $(eval $(call BuildPlugin,xml-radius,Radius authentication and authorization,vanilla,,,,+freeradius-client @BROKEN)) # freeradius-client isn't yet supported by OpenWRT.
 $(eval $(call BuildPlugin,xml-scgi,SCGI XML Gateway,vanilla,,,,))
-$(eval $(call BuildPlugin,yaml,YAML langunage,vanilla,,,,+libyaml @BROKEN))
+$(eval $(call BuildPlugin,yaml,YAML language,vanilla,,,,+libyaml @BROKEN))
index 2df16ff..5f93173 100644 (file)
@@ -47,7 +47,7 @@
      else
        AC_MSG_RESULT([no]); AM_CONDITIONAL([HAVE_LDNS],[false])
      fi],[
-@@ -1269,36 +1268,39 @@ AM_CONDITIONAL([HAVE_MYSQL],[test "$foun
+@@ -1269,21 +1268,21 @@ AM_CONDITIONAL([HAVE_MYSQL],[test "$foun
  # perl checks
  #
  
     AC_CHECK_HEADER([EXTERN.h], [ac_cv_have_EXTERN_h=yes], [ac_cv_have_EXTERN_h=no], [[#include <EXTERN.h>
  # include <perl.h>]])
     CFLAGS="$save_CFLAGS"
+@@ -1291,14 +1290,17 @@ if test "x$ac_cv_have_perl" != "xno"; th
     save_LDFLAGS="$LDFLAGS"
--   LDFLAGS="$PERL_LDFLAGS"
-+   LDFLAGS="${PERL_LDFLAGS}"
+    LDFLAGS="$PERL_LDFLAGS"
     AC_CHECK_LIB([perl], [perl_alloc], ac_cv_use_libperl=yes, ac_cv_use_libperl=no)
-    LDFLAGS="$save_LDFLAGS"
+-   LDFLAGS="$save_LDFLAGS"
++   LDFLAGS+="$save_LDFLAGS"
  
 -   AC_SUBST(PERL_SITEDIR)
 -   AC_SUBST(PERL_LIBDIR)
index f9f99c9..4226046 100644 (file)
@@ -21,7 +21,7 @@
  
  src/include/switch_swigable_cpp.h: $(switch_srcdir)/src/include/switch_cpp.h
 -      cat $(switch_srcdir)/src/include/switch_cpp.h | perl $(switch_srcdir)/build/strip.pl > $(switch_srcdir)/src/include/switch_swigable_cpp.h
-+      cat $(switch_srcdir)/src/include/switch_cpp.h | $(STAGING_DIR_HOST)/usr/bin/perl $(switch_srcdir)/build/strip.pl > $(switch_srcdir)/src/include/switch_swigable_cpp.h
++      cat $(switch_srcdir)/src/include/switch_cpp.h | $(STAGING_DIR)/../host/usr/bin/perl $(switch_srcdir)/build/strip.pl > $(switch_srcdir)/src/include/switch_swigable_cpp.h
  #     $(CC) -E $(switch_srcdir)/src/include/switch_cpp.h \
  #             -I$(switch_srcdir)/src/include -I$(switch_srcdir)/libs/libteletone/src \
  #             -DSWITCH_DECLARE_CLASS= -DSWITCH_DECLARE\(x\)=x -DSWITCH_DECLARE_CONSTRUCTOR= \
@@ -41,7 +41,7 @@
 -      cd libs/tiff-4.0.2 && sh ./configure.gnu $(MY_DEFAULT_ARGS)
 +      cd libs/tiff-4.0.2 && sh ./configure.gnu $(MY_DEFAULT_ARGS) --host="$(GNU_TARGET_NAME)" --prefix="/usr"
 +      cd libs/spandsp && autoreconf -fi
-+      cd libs/spandsp && sh ./configure.gnu --host="$(GNU_TARGET_NAME)" --prefix="/usr"
++      cd libs/spandsp && sh ./configure.gnu $(MY_DEFAULT_ARGS) --host="$(GNU_TARGET_NAME)" --prefix="/usr"
        cd libs/tiff-4.0.2 && make
  
  python-reconf:
index 06bc418..2872754 100644 (file)
@@ -5,7 +5,7 @@
  mod_ldap_la_LDFLAGS  = -avoid-version -module -no-undefined -shared
  
 -MY_DEFAULT_ARGS= --build=$(build) --host=$(host) --target=$(target) --prefix="$(prefix)" --exec_prefix="$(exec_prefix)" --libdir="$(libdir)" --disable-slapd --disable-bdb --disable-hdb
-+MY_DEFAULT_ARGS= --build=$(build) --host=$(host) --target=$(target) --prefix="$(prefix)" --exec_prefix="$(exec_prefix)" --libdir="$(libdir)" --host=$(host) --with-yielding_select=yes --disable-slapd --disable-bdb --disable-hdb
++MY_DEFAULT_ARGS= --build=$(build) --host=$(host) --target=$(target) --prefix="$(prefix)" --exec_prefix="$(exec_prefix)" --libdir="$(libdir)" --with-yielding_select=yes --disable-slapd --disable-bdb --disable-hdb
  
  $(MODNAME).lo: $(LDAPLA) $(LIBLBERLA)