BB: lantiq: falcon/vr9 - vpe softdog
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Nov 2014 08:32:32 +0000 (08:32 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Nov 2014 08:32:32 +0000 (08:32 +0000)
(required not-distributable firmware blob - dump it by yourself from original firmware)

Signed-off-by: Eddi De Pieri <eddi@depieri.net>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@43157 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/patches-3.10/0153-lantiq-VPE-softdog.patch [new file with mode: 0644]

diff --git a/target/linux/lantiq/patches-3.10/0153-lantiq-VPE-softdog.patch b/target/linux/lantiq/patches-3.10/0153-lantiq-VPE-softdog.patch
new file mode 100644 (file)
index 0000000..d1382e7
--- /dev/null
@@ -0,0 +1,171 @@
+--- /dev/null
++++ b/arch/mips/include/asm/mach-lantiq/vpe.h
+@@ -0,0 +1,44 @@
++/*
++ *   This program is free software; you can redistribute it and/or modify
++ *   it under the terms of the GNU General Public License as published by
++ *   the Free Software Foundation; either version 2 of the License, or
++ *   (at your option) any later version.
++ *
++ *   This program is distributed in the hope that it will be useful,
++ *   but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *   GNU General Public License for more details.
++ *
++ *   You should have received a copy of the GNU General Public License
++ *   along with this program; if not, write to the Free Software
++ *   Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
++ *
++ *   Copyright (C) 2005 infineon
++ *   Copyright (C) 2007 John Crispin <blogic@openwrt.org>
++ *
++ */
++#ifndef _IFXMIPS_VPE_H__
++#define _IFXMIPS_VPE_H__
++
++/* For the explanation of the APIs please refer the section "MT APRP Kernel
++ * Programming" in AR9 SW Architecture Specification
++ */
++int32_t vpe1_sw_start(void* sw_start_addr, uint32_t tcmask, uint32_t flags);
++int32_t vpe1_sw_stop(uint32_t flags);
++uint32_t vpe1_get_load_addr (uint32_t flags);
++uint32_t vpe1_get_max_mem (uint32_t flags);
++
++int32_t vpe1_set_boot_param(char *field, char *value, char flags);
++int32_t vpe1_get_boot_param(char *field, char **value, char flags);
++
++/* Watchdog APIs */
++extern unsigned long vpe1_wdog_ctr;
++extern unsigned long vpe1_wdog_timeout;
++
++unsigned long vpe1_sw_wdog_start(unsigned long);
++unsigned long vpe1_sw_wdog_stop(unsigned long);
++
++typedef int (*VPE_SW_WDOG_RESET)(unsigned long wdog_cleared_ok_count);
++int32_t vpe1_sw_wdog_register_reset_handler(VPE_SW_WDOG_RESET reset_fn);
++
++#endif
+--- /dev/null
++++ b/arch/mips/lantiq/softdog_vpe.c
+@@ -0,0 +1,109 @@
++/*
++** =============================================================================
++** FILE NAME     : softdog_vpe.c
++** MODULES       : LXDB
++** DATE          : 24-03-2008
++** AUTHOR        : LXDB Team
++** DESCRIPTION   : This header file contains the code for the watchdog
++**                 implentation on vpe1 side.
++** REFERENCES    :
++** COPYRIGHT     : Copyright (c) 2008
++**                 Am Campeon 1-12, 85579 Neubiberg, Germany
++** Any use of this software is subject to the conclusion of a respective
++** License agreement. Without such a License agreement no rights to the
++** software are granted
++**
++** HISTORY       :
++** $Date   $Author    $Comment
++** 24-03-2008   LXDB    Initial version
++** ============================================================================
++*/
++
++#include <linux/module.h>
++#include <linux/moduleparam.h>
++#include <linux/types.h>
++#include <linux/timer.h>
++#include <linux/reboot.h>
++#include <linux/init.h>
++#include <linux/jiffies.h>
++
++#include <vpe.h>
++
++static unsigned long last_wdog_value;
++static unsigned long vpe1_wdog_cleared;
++
++static unsigned long vpe1_wdog_dead;
++static void watchdog_vpe0_fire(unsigned long); /* Called when vpe0 timer expires */
++static void keep_alive_vpe0(unsigned long);
++VPE_SW_WDOG_RESET reset_local_fn;
++
++
++static struct timer_list watchdog_vpe0_ticktock =
++                TIMER_INITIALIZER(watchdog_vpe0_fire, 0, 0);
++
++static void watchdog_vpe0_fire (unsigned long flags)
++{
++      volatile unsigned long *wdog_ctr_value;
++      wdog_ctr_value = (void*)vpe1_wdog_ctr;
++      if (*wdog_ctr_value == last_wdog_value) { /* VPE1 watchdog expiry handling */
++              vpe1_sw_wdog_stop(flags);
++              vpe1_wdog_dead++;
++              printk(KERN_DEBUG "VPE1 watchdog reset handler called\n");
++      /* Call the reset handler function */
++              reset_local_fn(flags);
++      } else { /* Everything is OK on vpe1 side. Continue. */
++              last_wdog_value = *wdog_ctr_value;
++              vpe1_wdog_cleared++;
++              keep_alive_vpe0(flags);
++      }
++}
++
++int32_t vpe1_sw_wdog_register_reset_handler (VPE_SW_WDOG_RESET reset_fn)
++{
++      reset_local_fn = (VPE_SW_WDOG_RESET)reset_fn;
++      return 0;
++}
++
++static void keep_alive_vpe0(unsigned long flags)
++{
++      mod_timer(&watchdog_vpe0_ticktock, jiffies+ vpe1_wdog_timeout );
++}
++
++unsigned long vpe1_sw_wdog_start(unsigned long flags)
++{
++      volatile unsigned long *wdog_ctr_value;
++      wdog_ctr_value = (void*)vpe1_wdog_ctr;
++      *wdog_ctr_value = 0;
++      last_wdog_value = 0;
++      keep_alive_vpe0(flags);
++      return 0;
++}
++
++unsigned long vpe1_sw_wdog_stop(unsigned long flags)
++{
++      del_timer(&watchdog_vpe0_ticktock);
++      return 0;
++}
++
++static int __init watchdog_vpe1_init(void)
++{
++      /* Nothing to be done here */
++      return 0;
++}
++
++static void __exit watchdog_vpe1_exit(void)
++{
++      unsigned long flags=0;
++      vpe1_sw_wdog_stop(flags);
++}
++
++module_init(watchdog_vpe1_init);
++module_exit(watchdog_vpe1_exit);
++
++EXPORT_SYMBOL(vpe1_sw_wdog_register_reset_handler);
++EXPORT_SYMBOL(vpe1_sw_wdog_start);
++EXPORT_SYMBOL(vpe1_sw_wdog_stop);
++
++MODULE_AUTHOR("LXDB");
++MODULE_DESCRIPTION("Software Watchdog For VPE1");
++MODULE_LICENSE("GPL");
+
+--- a/arch/mips/lantiq/Makefile        2014-10-15 21:41:46.000000000 +0200
++++ b/arch/mips/lantiq/Makefile        2014-10-19 22:44:44.000000000 +0200
+@@ -4,7 +4,7 @@
+ # under the terms of the GNU General Public License version 2 as published
+ # by the Free Software Foundation.
+-obj-y := irq.o clk.o prom.o
++obj-y := irq.o clk.o prom.o softdog_vpe.o
+ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o