strongswan: add missing config files for plugins master
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 Apr 2014 17:20:12 +0000 (17:20 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 Apr 2014 17:20:12 +0000 (17:20 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Backport of r40524

git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_12.09@40525 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/strongswan/Makefile

index a0a8a6c..a85a01b 100644 (file)
@@ -316,13 +316,22 @@ define BuildPlugin
     DEPENDS:= +strongswan $(3)
   endef
 
+  strongswan_mod_conf=$(wildcard $(PKG_INSTALL_DIR)/etc/strongswan.d/charon/$(1).conf)
   define Package/strongswan-mod-$(1)/install
+       $(INSTALL_DIR) $$(1)/etc/strongswan.d/charon
+       $(if $(call strongswan_mod_conf,$(1)), \
+               $(INSTALL_DATA) \
+                       $(call strongswan_mod_conf,$(1)) \
+                       $$(1)/etc/strongswan.d/charon/ \
+       )
        $(INSTALL_DIR) $$(1)/usr/lib/ipsec/plugins
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/ipsec/plugins/libstrongswan-$(1).so \
                $$(1)/usr/lib/ipsec/plugins/
        $(call Plugin/$(1)/install,$$(1))
   endef
 
+  Package/strongswan-mod-$(1)/conffiles=$(patsubst $(PKG_INSTALL_DIR)%,%,$(call strongswan_mod_conf,$(1)))
+
   $$(eval $$(call BuildPackage,strongswan-mod-$(1)))
 endef