[packages_10.03.2] bandwidthd: merge r28946, r29199
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:41:38 +0000 (16:41 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:41:38 +0000 (16:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30288 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/bandwidthd/Makefile
utils/bandwidthd/files/bandwidthd.init

index 3121c68..3ae7d51 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bandwidthd
 PKG_VERSION:=2.0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/bandwidthd
@@ -53,4 +53,8 @@ define Package/bandwidthd/install
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/htdocs/logo.gif $(1)/www/
 endef
 
+define Package/bandwidthd/conffiles
+/etc/config/bandwidthd
+endef
+
 $(eval $(call BuildPackage,bandwidthd))
index 3b3819d..6483daa 100644 (file)
@@ -1,5 +1,6 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
+
 START=99
 
 config_cb() {
@@ -79,9 +80,9 @@ start() {
                unset conffile
        done
        cd /
-       bandwidthd
+       service_start /usr/sbin/bandwidthd
 }
 
 stop() {
-       killall bandwidthd
+       service_stop /usr/sbin/bandwidthd
 }