[packages_10.03.2] anyremote: merge r28945, r29199
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:40:26 +0000 (16:40 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:40:26 +0000 (16:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30286 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/anyremote/Makefile
utils/anyremote/files/anyremote.init

index 2c617df..bf2930d 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=anyremote
 PKG_VERSION:=4.7.1
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/${PKG_NAME}
@@ -44,4 +44,8 @@ define Package/anyremote/install
        $(INSTALL_BIN) ./files/anyremote.init $(1)/etc/init.d/anyremote
 endef
 
+define Package/anyremote/conffiles
+/etc/anyremote.cfg
+endef
+
 $(eval $(call BuildPackage,anyremote))
index e32b615..af05f49 100644 (file)
@@ -1,13 +1,15 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
+
 START=95
 
+SERVICE_DAEMONIZE=1
+SERVICE_WRITE_PID=1
+
 start() {
-    /usr/sbin/anyremote -f /etc/anyremote.cfg > /dev/null &
+       service_start /usr/sbin/anyremote -f /etc/anyremote.cfg
 }
-    
+
 stop() {
-    killall anyremote
+       service_stop /usr/sbin/anyremote
 }
-       
-