[packages_10.03.2] lcd4linux: Backfire does not implement log2f(), workaround with...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Feb 2012 16:14:34 +0000 (16:14 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Feb 2012 16:14:34 +0000 (16:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30338 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/lcd4linux/Makefile
utils/lcd4linux/patches/100-drv_RouterBoard.patch
utils/lcd4linux/patches/110-uclibc-logarithm-fix.patch
utils/lcd4linux/patches/120-remove_parport_outb.patch
utils/lcd4linux/patches/140-no_repnop_T6963.patch
utils/lcd4linux/patches/150-addlibmpdclient.patch
utils/lcd4linux/patches/160-uinput_defs.patch
utils/lcd4linux/patches/170-no-log2f.patch [new file with mode: 0644]

index 9d8295b..efc5a06 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=lcd4linux
 PKG_REV:=1159
 PKG_VERSION:=r$(PKG_REV)
-PKG_RELEASE:=3
+PKG_RELEASE:=3.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://ssl.bulix.org/svn/lcd4linux/trunk/
index ff9ab27..9780f5a 100644 (file)
@@ -1,7 +1,5 @@
-Index: lcd4linux-847/drv_RouterBoard.c
-===================================================================
---- lcd4linux-847.orig/drv_RouterBoard.c       2007-12-01 17:15:10.000000000 +0100
-+++ lcd4linux-847/drv_RouterBoard.c    2007-12-01 17:15:10.000000000 +0100
+--- a/drv_RouterBoard.c
++++ b/drv_RouterBoard.c
 @@ -106,7 +106,7 @@
  #include <string.h>
  #include <errno.h>
index 9deba8c..8f6d861 100644 (file)
@@ -1,6 +1,6 @@
 --- a/plugin_netinfo.c
 +++ b/plugin_netinfo.c
-@@ -264,7 +264,7 @@
+@@ -264,7 +264,7 @@ static void my_netmask_short(RESULT * re
      sin = get_netmask(arg1);
      if (NULL != sin) {
        logval = (long double) (get_netmask(arg1)->sin_addr.s_addr);
index 9ae1d0b..68d4bd4 100644 (file)
@@ -1,7 +1,5 @@
-Index: lcd4linux-847/drv_generic_parport.c
-===================================================================
---- lcd4linux-847.orig/drv_generic_parport.c   2007-12-01 17:15:10.000000000 +0100
-+++ lcd4linux-847/drv_generic_parport.c        2007-12-01 17:15:11.000000000 +0100
+--- a/drv_generic_parport.c
++++ b/drv_generic_parport.c
 @@ -39,16 +39,6 @@
  #include <sys/stat.h>
  #include <sys/ioctl.h>
@@ -19,9 +17,9 @@ Index: lcd4linux-847/drv_generic_parport.c
  #if defined (HAVE_LINUX_PARPORT_H) && defined (HAVE_LINUX_PPDEV_H)
  #define WITH_PPDEV
  #include <linux/parport.h>
-@@ -65,6 +55,11 @@
- #define PARPORT_STATUS_BUSY       0x80
- #endif
+@@ -68,6 +58,11 @@
+ /* these signals are inverted by hardware on the parallel port */
+ #define PARPORT_CONTROL_INVERTED (PARPORT_CONTROL_STROBE | PARPORT_CONTROL_SELECT | PARPORT_CONTROL_AUTOFD)
  
 +#ifndef WITH_OUTB
 +#define inb(foo) 0
index 9c224df..31ac8a5 100644 (file)
@@ -1,8 +1,6 @@
-Index: lcd4linux-847/drv_T6963.c
-===================================================================
---- lcd4linux-847.orig/drv_T6963.c     2007-12-01 17:15:10.000000000 +0100
-+++ lcd4linux-847/drv_T6963.c  2007-12-01 17:15:11.000000000 +0100
-@@ -114,7 +114,9 @@
+--- a/drv_T6963.c
++++ b/drv_T6963.c
+@@ -114,7 +114,9 @@ static void drv_T6_status1(void)
      /* wait for STA0=1 and STA1=1 */
      n = 0;
      do {
@@ -12,7 +10,7 @@ Index: lcd4linux-847/drv_T6963.c
        if (++n > 1000) {
            debug("hang in status1");
            bug = 1;
-@@ -150,7 +152,9 @@
+@@ -150,7 +152,9 @@ static void drv_T6_status2(void)
      /* wait for STA3=1 */
      n = 0;
      do {
index 7e0c2b2..0e51f67 100644 (file)
@@ -1,6 +1,5 @@
-diff -urN lcd4linux-r870.orig/libmpdclient.c lcd4linux-r870/libmpdclient.c
---- lcd4linux-r870.orig/libmpdclient.c 1970-01-01 01:00:00.000000000 +0100
-+++ lcd4linux-r870/libmpdclient.c      2008-03-26 04:43:31.000000000 +0100
+--- /dev/null
++++ b/libmpdclient.c
 @@ -0,0 +1,1957 @@
 +/* libmpdclient
 +   (c)2003-2006 by Warren Dukes (warren.dukes@gmail.com)
@@ -1959,9 +1958,8 @@ diff -urN lcd4linux-r870.orig/libmpdclient.c lcd4linux-r870/libmpdclient.c
 +    free(sPlaylist);
 +    free(string);
 +}
-diff -urN lcd4linux-r870.orig/libmpdclient.h lcd4linux-r870/libmpdclient.h
---- lcd4linux-r870.orig/libmpdclient.h 1970-01-01 01:00:00.000000000 +0100
-+++ lcd4linux-r870/libmpdclient.h      2008-03-26 04:43:32.000000000 +0100
+--- /dev/null
++++ b/libmpdclient.h
 @@ -0,0 +1,661 @@
 +/* libmpdclient
 +   (c)2003-2006 by Warren Dukes (warren.dukes@gmail.com)
index 5c7b98f..44b24b3 100644 (file)
@@ -1,6 +1,5 @@
-diff -urN lcd4linux-r877/drv_G15.c lcd4linux-r877.new/drv_G15.c
---- lcd4linux-r877/drv_G15.c   2008-06-01 22:47:45.000000000 +0200
-+++ lcd4linux-r877.new/drv_G15.c       2008-08-06 17:31:04.000000000 +0200
+--- a/drv_G15.c
++++ b/drv_G15.c
 @@ -42,6 +42,7 @@
  
  #include <usb.h>
@@ -9,7 +8,7 @@ diff -urN lcd4linux-r877/drv_G15.c lcd4linux-r877.new/drv_G15.c
  #include <linux/input.h>
  #include <linux/uinput.h>
  
-@@ -258,8 +259,13 @@
+@@ -269,8 +270,13 @@ void drv_G15_initKeyHandling(char *devic
      }
      memset(&device, 0, sizeof(device));
      strncpy(device.name, "G15 Keys", UINPUT_MAX_NAME_SIZE);
diff --git a/utils/lcd4linux/patches/170-no-log2f.patch b/utils/lcd4linux/patches/170-no-log2f.patch
new file mode 100644 (file)
index 0000000..5f2aa76
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/plugin_netinfo.c
++++ b/plugin_netinfo.c
+@@ -264,7 +264,7 @@ static void my_netmask_short(RESULT * re
+     sin = get_netmask(arg1);
+     if (NULL != sin) {
+       logval = (long double) (get_netmask(arg1)->sin_addr.s_addr);
+-      netlen = (int) rint(log2f(logval) / log2f(2.0));
++      netlen = (int) rint((logf(logval)/logf(2)) / (logf(2.0)/logf(2)));
+       qprintf(value, sizeof(value), "/%d", netlen);
+     } else {
+       qprintf(value, sizeof(value), "/?");