[packages_10.03.2] vpzone: merge r29094
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:34:04 +0000 (16:34 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:34:04 +0000 (16:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30278 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/vpzone/Makefile
net/vpzone/files/vpzone.init

index 2b19876..bcaeeaf 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vpzone
 PKG_VERSION:=0.1.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/vpzone
index 8007ff7..e78a0b7 100644 (file)
@@ -1,13 +1,15 @@
 #!/bin/sh /etc/rc.common
+# Copyright (C) 2010-2011 OpenWrt.org
 
 START=50
-DAEMON=vpzone
-PID_F=/var/run/$DAEMON.pid
+
+SERVICE_DAEMONIZE=1
+SERVICE_WRITE_PID=1
 
 start() {
-       start-stop-daemon -p $PID_F -x $DAEMON -S -b -m
+       service_start /usr/bin/vpzone
 }
 
 stop() {
-       start-stop-daemon -p $PID_F -x $DAEMON -K
+       service_stop /usr/bin/vpzone
 }