[packages_10.03.2] updatedd: merge r29069
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:32:01 +0000 (16:32 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:32:01 +0000 (16:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30276 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/updatedd/Makefile
net/updatedd/files/updatedd.init

index e28070e..3bb15ba 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=updatedd
 PKG_VERSION:=2.6
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.bz2
index d364659..5ae4545 100644 (file)
@@ -1,14 +1,15 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-start_service () {
+start_instance () {
        local section="$1"
-       config_get service  "$section" service
-       config_get username "$section" username
-       config_get password "$section" password
-       config_get host     "$section" host
-       config_get update   "$section" update
+       config_get service  "$section" 'service'
+       config_get username "$section" 'username'
+       config_get password "$section" 'password'
+       config_get host     "$section" 'host'
+       config_get update   "$section" 'update'
 
        [ "$update" = 1 ] && {
                if [ "$service" = "dyndns" ]; then
@@ -22,16 +23,16 @@ start_service () {
                        fi
                fi
                if [ "$abusive" != "1" ]; then
-                       /usr/bin/updatedd -Y $service -- $username:$password $host
+                       service_start /usr/bin/updatedd -Y $service -- $username:$password $host
                fi
        }
 }
 
 start() {
-       config_load "updatedd"
-       config_foreach start_service updatedd
+       config_load 'updatedd'
+       config_foreach start_instance 'updatedd'
 }
 
 stop() {
-       killall updatedd
+       service_stop /usr/bin/updatedd
 }