[packages_10.03.2] vsftpd: merge r28907
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:34:55 +0000 (16:34 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:34:55 +0000 (16:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30280 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/vsftpd/Makefile
net/vsftpd/files/vsftpd.init

index a1e7147..32cae30 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
 PKG_VERSION:=2.3.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://security.appspot.com/downloads/
index 303d6cf..ad3e23d 100644 (file)
@@ -1,14 +1,13 @@
 #!/bin/sh /etc/rc.common
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=50
 
-RUN_D=/var/run/vsftpd
-
 start() {
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       vsftpd
+       mkdir -m 0755 -p /var/run/vsftpd
+       service_start /usr/sbin/vsftpd
 }
 
 stop() {
-       killall vsftpd
+       service_stop /usr/sbin/vsftpd
 }