[backfire] libnl-tiny: backport r31155
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Apr 2012 05:43:18 +0000 (05:43 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Apr 2012 05:43:18 +0000 (05:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@31156 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libnl-tiny/Makefile
package/libnl-tiny/src/socket.c

index 4b02ef1..51ad541 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl-tiny
 PKG_VERSION:=0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2.1
 
 include $(INCLUDE_DIR)/package.mk
 
index 6fe56fd..1429825 100644 (file)
@@ -59,7 +59,7 @@ static void release_local_port(uint32_t port)
                return;
        
        nr = port >> 22;
-       used_ports_map[nr / 32] &= ~((nr % 32) + 1);
+       used_ports_map[nr / 32] &= ~(1 << nr % 32);
 }
 
 /**