net/freeswitch: Fixed mod_syslog enable for both -upstream-defaults and -minimal
authorcshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Jun 2010 19:30:18 +0000 (19:30 +0000)
committercshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Jun 2010 19:30:18 +0000 (19:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21971 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/freeswitch/Makefile
net/freeswitch/files/etc.minimal/autoload_configs/modules.conf.xml

index 6dfae88..1e9c1fa 100644 (file)
@@ -374,8 +374,8 @@ define Build/Compile
                DESTDIR="$(PKG_INSTALL_DIR)" \
                LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
                all $(MAKE_INSTALL_TARGETS)
-       $(SED) 's|^\([:blank:]*\)\(.*\)"mod_console"\(.*\)$$$$|\1<!-- \2"mod_console"\3 -->|' $(PKG_INSTALL_DIR)/etc/freeswitch/autoload_configs/modules.conf.xml
-       $(SED) 's|^\([:blank:]*\)<!-- \(.*\)"mod_syslog"\(.*\) -->\(.*\)$$$$|\1\2"mod_syslog"\3\4 -->|' $(PKG_INSTALL_DIR)/etc/freeswitch/autoload_configs/modules.conf.xml
+       $(SED) 's|^\([ \t]*\)\(.*\)"mod_console"\(.*\)$$$$|\1<!-- \2"mod_console"\3 -->|' $(PKG_INSTALL_DIR)/etc/freeswitch/autoload_configs/modules.conf.xml
+       $(SED) 's|^\([ \t]*\)<!-- \(.*\)"mod_syslog"\(.*\) -->\(.*\)$$$$|\1\2"mod_syslog"\3\4|' $(PKG_INSTALL_DIR)/etc/freeswitch/autoload_configs/modules.conf.xml
 endef
 
 define Build/InstallDev
index c5b3307..be17899 100644 (file)
@@ -2,8 +2,8 @@
   <modules>
     
     <!-- Loggers (I'd load these first) -->
-    <load module="mod_console"/>
-    <!-- <load module="mod_logfile"/> -->
+    <!-- <load module="mod_console"/> -->
+    <load module="mod_logfile"/>
     <!-- <load module="mod_syslog"/> -->
 
     <!--<load module="mod_yaml"/>-->