Update bluez-utils to 3.35 (#3725)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2008 18:42:38 +0000 (18:42 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2008 18:42:38 +0000 (18:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11736 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/bluez-utils/Makefile
utils/bluez-utils/patches/200-uart-speed.patch [new file with mode: 0644]

index 6dd926b..d5dda10 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
-PKG_VERSION:=3.24
-PKG_RELEASE:=4
+PKG_VERSION:=3.35
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
-PKG_MD5SUM:=cc3582da827bc4c468147af1afaa5aff
+PKG_MD5SUM:=21dc2f8c03dae9db87da351c735510bb
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/bluez-utils
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+bluez-libs +libpthread +dbus
+  DEPENDS:=+bluez-libs +libpthread +dbus +libintl +libiconv
   TITLE:=Bluetooth utilities
   URL:=http://www.bluez.org/
 endef
@@ -35,21 +35,22 @@ define Package/bluez-utils/conffiles
 /etc/config/bluetooth
 endef
 
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-debug \
-               --enable-usb \
-               --enable-input \
-               --enable-serial \
-               --enable-network \
-               --with-bluez="$(STAGING_DIR)/usr/include" \
-               --with-usb=yes \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-pand \
+       --enable-rfcomm \
+       --enable-dund \
+       --enable-serial \
+       --enable-network \
+       --enable-usb \
+       --enable-input \
+       --with-bluez="$(STAGING_DIR)/usr/include" \
+       --with-usb=yes \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib \
+                       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+                       -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
@@ -67,7 +68,6 @@ define Package/bluez-utils/install
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/bluetooth.conf $(1)/etc/config/bluetooth
        $(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/../daemon/bluetooth.conf $(1)/etc/dbus-1/system.d/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/bluez-utils.init $(1)/etc/init.d/bluez-utils
 endef
diff --git a/utils/bluez-utils/patches/200-uart-speed.patch b/utils/bluez-utils/patches/200-uart-speed.patch
new file mode 100644 (file)
index 0000000..15a99f4
--- /dev/null
@@ -0,0 +1,41 @@
+diff -Naur bluez-utils-3.35.ori/tools/hciattach.c bluez-utils-3.35/tools/hciattach.c
+--- bluez-utils-3.35.ori/tools/hciattach.c     2008-05-20 18:14:39.000000000 +0200
++++ bluez-utils-3.35/tools/hciattach.c 2008-07-06 13:01:28.000000000 +0200
+@@ -108,20 +108,37 @@
+               return B230400;
+       case 460800:
+               return B460800;
++/* FIX: Not all platform support this high serial speed
++   claudyus84 @gamil.com
++*/
++#ifdef B500000
+       case 500000:
+               return B500000;
++#endif
++#ifdef B576000
+       case 576000:
+               return B576000;
++#endif
++#ifdef B921600
+       case 921600:
+               return B921600;
++#endif
++#ifdef B1000000
+       case 1000000:
+               return B1000000;
++#endif
++#ifdef B1152000
+       case 1152000:
+               return B1152000;
++#endif
++#ifdef B1500000
+       case 1500000:
+               return B1500000;
++#endif
++#ifdef B2000000
+       case 2000000:
+               return B2000000;
++#endif
+ #ifdef B2500000
+       case 2500000:
+               return B2500000;