hostapd: use -ffunction-sections, -fdata-sections and --gc-sections, reduces binary...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Mar 2011 12:01:08 +0000 (12:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Mar 2011 12:01:08 +0000 (12:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25821 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostapd/Makefile

index 3b4978f..83622b4 100644 (file)
@@ -225,6 +225,9 @@ TARGET_CPPFLAGS := \
        -DCONFIG_LIBNL20 \
        -D_GNU_SOURCE
 
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
 ifdef CONFIG_PACKAGE_kmod-mac80211
   TARGET_LDFLAGS += -lm -lnl-tiny
 endif