mysql: version bump to 5.1.68
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Feb 2013 12:13:45 +0000 (12:13 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Feb 2013 12:13:45 +0000 (12:13 +0000)
This patch bumps MySQL to latest version and also repairs
missing/not working mirrors (planetmirror is offline and
holywar.net does not provide mysql anymore). If a source
package does not exist at mirror repo (they seem to keep
the latest two versions at mysql repo), it uses the archives
repo at last.

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35637 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/mysql/Makefile

index 56b5d1b..1f756b9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/uclibc++.mk
 
 PKG_NAME:=mysql
-PKG_VERSION:=5.1.66
-PKG_RELEASE:=7
+PKG_VERSION:=5.1.68
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=\
-       http://mysql.planetmirror.com/Downloads/MySQL-5.1/ \
        http://mysql.he.net/Downloads/MySQL-5.1/ \
        http://www.linorg.usp.br/mysql/Downloads/MySQL-5.1/ \
-       http://mysql.holywar.net/Downloads/MySQL-5.1/
-PKG_MD5SUM:=a43ffa58e3611e5a557feb745596aca3
+       http://www.mirrorservice.org/sites/ftp.mysql.com/Downloads/MySQL-5.1/ \
+       http://mirror.switch.ch/ftp/mirror/mysql/Downloads/MySQL-5.1/ \
+       http://downloads.mysql.com/archives/mysql-5.1/
+
+PKG_MD5SUM:=3a4a627d0865ce7660504728a15b0fb9
 
 PKG_BUILD_DEPENDS:=libncurses libreadline
 PKG_BUILD_PARALLEL:=1