[package] fix luasocket compilation failures (#6065)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 29 Oct 2009 10:59:47 +0000 (10:59 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 29 Oct 2009 10:59:47 +0000 (10:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18200 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/luasocket/Makefile

index d2673c2..3d503d7 100644 (file)
@@ -38,7 +38,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/ all \
        LIBDIR="$(TARGET_LDFLAGS)" \
-       CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+       CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -std=gnu99" \
        LD="$(TARGET_CROSS)ld -shared" 
 endef