[packages] freecwmp: should fix defconfig issue
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jun 2012 16:28:30 +0000 (16:28 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jun 2012 16:28:30 +0000 (16:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32410 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/freecwmp/Config-curl.in [deleted file]
utils/freecwmp/Config-zstream.in [deleted file]
utils/freecwmp/Config.in [new file with mode: 0644]
utils/freecwmp/Makefile

diff --git a/utils/freecwmp/Config-curl.in b/utils/freecwmp/Config-curl.in
deleted file mode 100644 (file)
index baff2ef..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-menu "Configuration"
-       depends on PACKAGE_freecwmp-curl
-
-config FREECWMP_SCRIPTS_FULL
-       bool "Install all freecwmp scripts"
-       default y
-
-choice
-       prompt "Select ACS sever"
-       default FREECWMP_ACS_MULTI
-
-config FREECWMP_ACS_MULTI
-       bool "No specific ACS, follow standard"
-
-config FREECWMP_ACS_HDM
-       bool "HDM"
-endchoice
-
-config FREECWMP_DEBUG
-       bool "Compile with debug options"
-       default n
-
-config FREECWMP_DEVEL_DEBUG
-       bool "Compile with development debug options"
-       default n
-
-endmenu
diff --git a/utils/freecwmp/Config-zstream.in b/utils/freecwmp/Config-zstream.in
deleted file mode 100644 (file)
index 465bfaa..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-menu "Configuration"
-       depends on PACKAGE_freecwmp-zstream
-
-config FREECWMP_SCRIPTS_FULL
-       bool "Install all freecwmp scripts"
-       default y
-
-choice
-       prompt "Select ACS sever"
-       default FREECWMP_ACS_MULTI
-
-config FREECWMP_ACS_MULTI
-       bool "No specific ACS, follow standard"
-
-config FREECWMP_ACS_HDM
-       bool "HDM"
-endchoice
-
-config FREECWMP_DEBUG
-       bool "Compile with debug options"
-       default n
-
-config FREECWMP_DEVEL_DEBUG
-       bool "Compile with development debug options"
-       default n
-
-endmenu
diff --git a/utils/freecwmp/Config.in b/utils/freecwmp/Config.in
new file mode 100644 (file)
index 0000000..95f3583
--- /dev/null
@@ -0,0 +1,26 @@
+if PACKAGE_freecwmp-curl || PACKAGE_freecwmp-zstream
+
+config FREECWMP_SCRIPTS_FULL
+       bool "Install all freecwmp scripts"
+       default y
+
+choice
+       prompt "Select ACS sever"
+       default FREECWMP_ACS_MULTI
+
+config FREECWMP_ACS_MULTI
+       bool "No specific ACS, follow standard"
+
+config FREECWMP_ACS_HDM
+       bool "HDM"
+endchoice
+
+config FREECWMP_DEBUG
+       bool "Compile with debug options"
+       default n
+
+config FREECWMP_DEVEL_DEBUG
+       bool "Compile with development debug options"
+       default n
+
+endif
index 9d2a85b..48acd3c 100644 (file)
@@ -33,8 +33,7 @@ define Package/freecwmp/Default
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=CWMP client
-  DEPENDS:=+libubox +libmicroxml +shflags @BROKEN
-  MENU:=1
+  DEPENDS:=+libuci +libubox +libmicroxml +shflags
 endef
 
 define Package/freecwmp/description
@@ -44,23 +43,19 @@ endef
 define Package/freecwmp-curl
   $(call Package/freecwmp/Default)
   TITLE+= (using libcurl)
-  DEPENDS += +libcurl
+  DEPENDS+= +libcurl
   VARIANT:=curl
 endef
 
 define Package/freecwmp-zstream
   $(call Package/freecwmp/Default)
-  TITLE += (using libzstream)
-  DEPENDS += +libzstream
+  TITLE+= (using libzstream)
+  DEPENDS+= +libzstream
   VARIANT:=zstream
 endef
 
-define Package/freecwmp-curl/config
-       source "$(SOURCE)/Config-curl.in"
-endef
-
 define Package/freecwmp-zstream/config
-       source "$(SOURCE)/Config-zstream.in"
+       source "$(SOURCE)/Config.in"
 endef
 
 USE_LOCAL=$(shell ls ./src/ 2>/dev/null >/dev/null && echo 1)