nut: install development files for libupsclient
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Dec 2012 18:25:35 +0000 (18:25 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Dec 2012 18:25:35 +0000 (18:25 +0000)
Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@34829 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/nut/Makefile

index 9d9ffd1..3fcfb7e 100644 (file)
@@ -75,6 +75,14 @@ define Package/nut/install
        ln -sf /var/run/ups.conf $(1)/etc/nut/ups.conf
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib
+endef
+
 define Package/nut/conffiles
 /etc/nut/nut.conf
 endef
@@ -282,7 +290,8 @@ CONFIGURE_ARGS += \
   --with-group=root \
   --with-usb \
   --with-snmp \
-  --without-libltdl
+  --without-libltdl \
+  --with-dev
 
 
 $(eval $(call BuildPackage,nut))