[package] Fix mysql dependencies
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Aug 2011 10:10:38 +0000 (10:10 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Aug 2011 10:10:38 +0000 (10:10 +0000)
Trying to fix some issues with php5 I discoverd that php5's mysql extension doesn't load:

<snip>
root@OpenWrt:/tmp# php-cli -m
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/mysql.so' - File not found in Unknown on line 0
[PHP Modules]
Core
ctype
curl
date
ereg
gettext
json
openssl
pcntl
pcre
posix
Reflection
session
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
zlib

[Zend Modules]
</snap>

After installing uclibcxx, the extension loads fine:

<snip>
root@OpenWrt:/tmp# opkg install uclibcxx
Installing uclibcxx (0.2.2-3) to root...
Downloading http://192.168.1.2:8081/brcm47xx/packages/uclibcxx_0.2.2-3_brcm47xx.ipk.
Configuring uclibcxx.
root@OpenWrt:/tmp# php-cli -m
[PHP Modules]
<...>
mysql
<...>

[Zend Modules]
</snap>

So the mysqlclient library needs uclibcxx, not only mysql-server. But since
mysql-server is depended of the mysqlclient library we can shorten its dependencies.

I also cross-checked that e.g. a mysql-enabled lighttpd shows the same behaviour
when uclibcxx is not installed.
<snip>
root@OpenWrt:/tmp/log/lighttpd# lighttpd -f /etc/lighttpd/lighttpd.conf
1970-01-01 05:07:30: (plugin.c.169) dlopen() failed for: /usr/lib/lighttpd/mod_mysql_vhost.so File not found
1970-01-01 05:07:30: (server.c.650) loading plugins finally failed
</snap>

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28083 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/mysql/Makefile

index 3dcae75..eeecfb0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mysql
 PKG_VERSION:=5.1.53
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=\
@@ -29,7 +29,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libmysqlclient/Default
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+zlib
+  DEPENDS:=+uclibcxx +zlib
   TITLE:=MySQL client library
   URL:=http://dev.mysql.com/
 endef
@@ -37,7 +37,7 @@ endef
 define Package/mysql-server/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+zlib +libmysqlclient +uclibcxx
+  DEPENDS:=+libmysqlclient
   TITLE:=MySQL Server
   URL:=http://dev.mysql.com/
   SUBMENU:=database