coreutils: fix build with uclibc 0.9.32
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 11 Dec 2010 13:30:44 +0000 (13:30 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 11 Dec 2010 13:30:44 +0000 (13:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24483 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/coreutils/Makefile

index 7103882..43e7946 100644 (file)
@@ -62,17 +62,14 @@ define Package/coreutils/description
         sufficient and much smaller.
 endef
 
-ifneq ($(CONFIG_USE_UCLIBC),)
-CONFIGURE_VARS += \
-       gl_cv_func_mbrtowc_incomplete_state=yes \
-       gl_cv_func_mbrtowc_retval=yes \
-       gl_cv_func_wcrtomb_retval=yes \
-       ac_cv_type_pthread_spinlock_t=no
-else
 CONFIGURE_VARS += \
        gl_cv_func_mbrtowc_incomplete_state=yes \
        gl_cv_func_mbrtowc_retval=yes \
        gl_cv_func_wcrtomb_retval=yes
+
+ifneq ($(CONFIG_USE_UCLIBC),)
+  CONFIGURE_VARS += \
+       ac_cv_type_pthread_spinlock_t=$(if $(filter 0.9.30% 0.9.2% 0.9.31%,$(call qstrip,$(CONFIG_UCLIBC_VERSION))),no,yes)
 endif
 
 CONFIGURE_ARGS += \