add gtk2 fix by larsc
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 22 Dec 2008 16:31:35 +0000 (16:31 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 22 Dec 2008 16:31:35 +0000 (16:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@13719 3c298f89-4303-0410-b956-a3cf2f4a3e73

Xorg/lib/gtk2/Makefile

index f03bf7c..d144968 100644 (file)
@@ -31,7 +31,7 @@ EXTRA_LDFLAGS+=\
        -L$(STAGING_DIR)/usr/lib/libiconv/lib/ \
        -L$(STAGING_DIR)/usr/lib/
 
-STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_gtk2 CONFIG_PACKAGE_gtk-cups2)
+STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_gtk2 CONFIG_PACKAGE_gtk2-cups)
 
 define Package/gtk2
   SECTION:=xorg-framework
@@ -60,7 +60,7 @@ define Build/Configure
                --disable-xinerama \
                --without-libjasper \
                --with-xinput \
-               $(if $(CONFIG_PACKAGE_gtk2-cups),--enable-cups,--disable-cups), \
+               $(if $(CONFIG_PACKAGE_gtk2-cups),--enable-cups=auto,--disable-cups), \
                gio_can_sniff=no \
        )
 endef