Revert "[package] shadow: rework Makefile" (should fix #13515)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 May 2013 15:45:25 +0000 (15:45 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 May 2013 15:45:25 +0000 (15:45 +0000)
This reverts commit 8c286b154eb0c4cf7e7d5e6f2cd8e33776188916.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@36612 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/shadow/Makefile

index fd2df65..7b9c352 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2013 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -16,12 +16,12 @@ PKG_SOURCE_URL:=http://pkg-shadow.alioth.debian.org/releases
 PKG_MD5SUM:=a00449aa439c69287b6d472191dc2247
 
 PKG_FIXUP:=autoreconf
-PKG_BUILD_PARALLEL:=1
+
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-SHADOW_APPLETS := \
+UTILS := \
        chage groupadd groupdel groupmod groups passwd su \
        useradd userdel usermod
 
@@ -34,20 +34,16 @@ CONFIGURE_ARGS += \
        --without-tcb \
        --without-nscd
 
-define Package/shadow/Default
+define Package/shadow
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=The PLD Linux shadow utilities
   URL:=http://pkg-shadow.alioth.debian.org/
-endef
-
-define Package/shadow
-  $(call Package/shadow/Default)
-  MENU:=1
+  DEPENDS:=$(foreach u,$(UTILS),+shadow-$(u))
 endef
 
 define Package/shadow/description
-  Full versions of standard shadow utilities. Normally, you would not
+  Full versions of standard shadow utilities.  Normally, you would not
   use this package, since the functionality in BusyBox is more than
   sufficient and much smaller.
 endef
@@ -58,28 +54,12 @@ endef
 
 
 define Package/shadow-common
-  $(call Package/shadow/Default)
-  TITLE:=Shared definitions for the PLD Linux shadow utilities
-  DEPENDS:=shadow
-endef
-
-
-define GenPlugin
-  define Package/shadow-$(1)
-    $(call Package/shadow/Default)
-    TITLE:=Utility $(1) from the PLD Linux shadow utilities
-    DEPENDS:=shadow +shadow-common
-  endef
-
-  define Package/shadow-$(1)/description
-    Full version of standard $(1) utility. Normally, you would not use this
-    package, since the functionality in BusyBox is more than sufficient.
-  endef
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Shared definitions for the shadow utilities
+  URL:=http://pkg-shadow.alioth.debian.org/
 endef
 
-$(foreach u,$(SHADOW_APPLETS),$(eval $(call GenPlugin,$(u))))
-
-
 define Package/shadow-common/conffiles
 /etc/login.defs
 endef
@@ -90,7 +70,20 @@ define Package/shadow-common/install
 endef
 
 
-define BuildPlugin
+define program
+  define Package/shadow-$(1)
+    SECTION:=utils
+    CATEGORY:=Utilities
+    TITLE:=Utility $(1) from the PLD Linux shadow utilities
+    URL:=http://pkg-shadow.alioth.debian.org/
+    DEPENDS:=+shadow-common
+  endef
+
+  define Package/shadow-$(1)/description
+    Full version of standard $(1) utility. Normally, you would not use this
+    package, since the functionality in BusyBox is more than sufficient.
+  endef
+
   define Package/shadow-$(1)/install
        [ -x "$(PKG_INSTALL_DIR)/usr/sbin/$(1)" ] && { \
                $(INSTALL_DIR) $$(1)/usr/sbin; \
@@ -104,7 +97,6 @@ define BuildPlugin
   $$(eval $$(call BuildPackage,shadow-$(1)))
 endef
 
-$(foreach u,$(SHADOW_APPLETS),$(eval $(call BuildPlugin,$(u))))
-
 $(eval $(call BuildPackage,shadow))
 $(eval $(call BuildPackage,shadow-common))
+$(foreach u,$(UTILS),$(eval $(call program,$(u))))