[package] libevent: move headers and libs to a specific sub-folder
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jul 2012 15:40:18 +0000 (15:40 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jul 2012 15:40:18 +0000 (15:40 +0000)
And update nfs-kernel-server to use these new headers location

git-svn-id: svn://svn.openwrt.org/openwrt/packages@32918 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libevent/Makefile
net/nfs-kernel-server/Makefile

index c00a0b1..781b87c 100644 (file)
@@ -52,10 +52,10 @@ MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)" \
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{a,so} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include/libevent
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/libevent/
+       $(INSTALL_DIR) $(1)/usr/lib/libevent
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{a,so} $(1)/usr/lib/libevent/
 endef
 
 define Package/libevent/install
index c98a204..aca76f6 100644 (file)
@@ -67,8 +67,10 @@ define Package/nfs-utils/description
   Updated mount.nfs command - allows mounting nfs4 volumes
 endef
 
-TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib -I$(STAGING_DIR)/usr/include -Drpc_uint=uint
-TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib $(LIBRPC)
+TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib -I$(STAGING_DIR)/usr/include/libevent \
+                -I$(STAGING_DIR)/usr/include/ -Drpc_uint=uint
+TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib $(LIBRPC) \
+                 -L$(STAGING_DIR)/usr/lib/libevent
 
 CONFIGURE_ARGS += \
        --disable-gss \