Package update-usbids.sh so that the list can be updated
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 13 Jul 2007 14:20:40 +0000 (14:20 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 13 Jul 2007 14:20:40 +0000 (14:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7969 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/usbutils/Makefile

index f247c2b..5da32ee 100644 (file)
@@ -30,6 +30,11 @@ define Package/usbutils
   URL:=http://linux-usb.sourceforge.net/
 endef
 
+define Package/usbutils/postinst
+#!/bin/sh
+$${IPKG_INSTROOT}/usr/sbin/update-usbids.sh
+endef
+
 # uses GNU configure
 
 define Build/Compile
@@ -41,6 +46,7 @@ endef
 define Package/usbutils/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lsusb $(1)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/update-usbids.sh $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/share
        $(CP) $(PKG_INSTALL_DIR)/usr/share/usb.ids $(1)/usr/share/
 endef