[packages] move and rename gettext to gettext-full
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Dec 2010 02:34:55 +0000 (02:34 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Dec 2010 02:34:55 +0000 (02:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24698 3c298f89-4303-0410-b956-a3cf2f4a3e73

16 files changed:
libs/gettext-full/Makefile [new file with mode: 0644]
libs/gettext-full/patches/001-autotools.patch [new file with mode: 0644]
libs/gettext-full/patches/001-no_examples_and_tests.patch [new file with mode: 0644]
libs/gettext-full/patches/003-gettext-error_print_progname.patch [new file with mode: 0644]
libs/gettext-full/patches/004-gnulib-uclibc-sched_param-def.patch [new file with mode: 0644]
libs/gettext-full/patches/100-error_progname.patch [new file with mode: 0644]
libs/gettext-full/patches/120-uclibc-nolocale.patch [new file with mode: 0644]
libs/gettext-full/patches/150-disable_libxml_iconv.patch [new file with mode: 0644]
libs/gettext/Makefile [deleted file]
libs/gettext/patches/001-autotools.patch [deleted file]
libs/gettext/patches/001-no_examples_and_tests.patch [deleted file]
libs/gettext/patches/003-gettext-error_print_progname.patch [deleted file]
libs/gettext/patches/004-gnulib-uclibc-sched_param-def.patch [deleted file]
libs/gettext/patches/100-error_progname.patch [deleted file]
libs/gettext/patches/120-uclibc-nolocale.patch [deleted file]
libs/gettext/patches/150-disable_libxml_iconv.patch [deleted file]

diff --git a/libs/gettext-full/Makefile b/libs/gettext-full/Makefile
new file mode 100644 (file)
index 0000000..860b79b
--- /dev/null
@@ -0,0 +1,63 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gettext-full
+PKG_VERSION:=0.18.1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=gettext-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/gettext
+PKG_MD5SUM:=3dd55b952826d2b32f51308f2f91aa89
+PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libintl-full
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=GNU Internationalization library
+  URL:=http://www.gnu.org/software/gettext/
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --enable-nls \
+       --disable-java \
+       --disable-native-java \
+       --disable-openmp \
+       --with-included-gettext \
+       --without-libintl-prefix \
+       --without-libexpat-prefix \
+       --without-emacs
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/gettext-full
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/include/libintl.h $(1)/usr/include/gettext-full/
+
+       $(INSTALL_DIR) $(1)/usr/lib/gettext-full
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libintl.{a,so*} $(1)/usr/lib/gettext-full/
+
+       $(INSTALL_DIR) $(1)/usr/share/aclocal
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
+endef
+
+define Package/libintl-full/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libintl.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libintl-full))
diff --git a/libs/gettext-full/patches/001-autotools.patch b/libs/gettext-full/patches/001-autotools.patch
new file mode 100644 (file)
index 0000000..bf44fcb
--- /dev/null
@@ -0,0 +1,35 @@
+--- a/gettext-runtime/man/Makefile.am
++++ b/gettext-runtime/man/Makefile.am
+@@ -159,8 +159,7 @@ bind_textdomain_codeset.3.html: bind_tex
+       $(MAN2HTML) $(srcdir)/bind_textdomain_codeset.3.in | sed -e '/CreationDate:/d' > t-$@
+       mv t-$@ $@
+-install-html-local:
+-      $(mkdir_p) $(DESTDIR)$(htmldir)
++install-html: installdirs-html
+       for file in $(man_HTML); do \
+         if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
+         $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
+--- a/gettext-tools/man/Makefile.am
++++ b/gettext-tools/man/Makefile.am
+@@ -186,8 +186,7 @@ autopoint.1.html: autopoint.1
+       $(MAN2HTML) `if test -f autopoint.1; then echo .; else echo $(srcdir); fi`/autopoint.1 | sed -e '/CreationDate:/d' > t-$@
+       mv t-$@ $@
+-install-html-local:
+-      $(mkdir_p) $(DESTDIR)$(htmldir)
++install-html: installdirs-html
+       for file in $(man_HTML); do \
+         if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
+         $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
+--- a/gettext-runtime/intl/Makefile.in
++++ b/gettext-runtime/intl/Makefile.in
+@@ -19,7 +19,7 @@
+ PACKAGE = @PACKAGE@
+ VERSION = @VERSION@
+-SHELL = /bin/sh
++SHELL = @SHELL@
+ srcdir = @srcdir@
+ top_srcdir = @top_srcdir@
diff --git a/libs/gettext-full/patches/001-no_examples_and_tests.patch b/libs/gettext-full/patches/001-no_examples_and_tests.patch
new file mode 100644 (file)
index 0000000..7cdb389
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/gettext-runtime/Makefile.in
++++ b/gettext-runtime/Makefile.in
+@@ -208,7 +208,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
+ ETAGS = etags
+ CTAGS = ctags
+ DIST_SUBDIRS = doc intl intl-java intl-csharp gnulib-lib libasprintf \
+-      src po man m4 tests
++      src po man m4
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ distdir = $(PACKAGE)-$(VERSION)
+ top_distdir = $(distdir)
+--- a/gettext-tools/Makefile.in
++++ b/gettext-tools/Makefile.in
+@@ -1248,7 +1248,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
+ ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
+-SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
++SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4
+ # Allow users to use "gnulib-tool --update".
diff --git a/libs/gettext-full/patches/003-gettext-error_print_progname.patch b/libs/gettext-full/patches/003-gettext-error_print_progname.patch
new file mode 100644 (file)
index 0000000..9e84551
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/gettext-tools/libgettextpo/error.h
++++ b/gettext-tools/libgettextpo/error.h
+@@ -49,7 +49,7 @@ extern void error_at_line (int __status,
+ /* If NULL, error will flush stdout, then print on stderr the program
+    name, a colon and a space.  Otherwise, error will call this
+    function without parameters instead.  */
+-extern DLL_VARIABLE void (*error_print_progname) (void);
++void (*error_print_progname) (void);
+ /* This variable is incremented each time `error' is called.  */
+ extern DLL_VARIABLE unsigned int error_message_count;
diff --git a/libs/gettext-full/patches/004-gnulib-uclibc-sched_param-def.patch b/libs/gettext-full/patches/004-gnulib-uclibc-sched_param-def.patch
new file mode 100644 (file)
index 0000000..051c374
--- /dev/null
@@ -0,0 +1,17 @@
+uclibc defines __GLIBC__ but it does not expose struct shed_param as much as glibc
+and is not needed too per standard. gnulib attempts to use it but we have to account
+for it because in this case uclibc does not behave like glibc.
+
+-Khem
+
+--- a/gettext-tools/gnulib-lib/spawn.in.h
++++ b/gettext-tools/gnulib-lib/spawn.in.h
+@@ -31,7 +31,7 @@
+ /* Get definitions of 'struct sched_param' and 'sigset_t'.
+    But avoid namespace pollution on glibc systems.  */
+-#ifndef __GLIBC__
++#if !defined __GLIBC__ || defined __UCLIBC__
+ # include <sched.h>
+ # include <signal.h>
+ #endif
diff --git a/libs/gettext-full/patches/100-error_progname.patch b/libs/gettext-full/patches/100-error_progname.patch
new file mode 100644 (file)
index 0000000..f414703
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/gettext-runtime/intl/intl-compat.c
++++ b/gettext-runtime/intl/intl-compat.c
+@@ -131,3 +131,7 @@ bind_textdomain_codeset (const char *dom
+ {
+   return libintl_bind_textdomain_codeset (domainname, codeset);
+ }
++
++#ifdef __UCLIBC__
++DLL_EXPORTED void (*error_print_progname)(void) = NULL;
++#endif
diff --git a/libs/gettext-full/patches/120-uclibc-nolocale.patch b/libs/gettext-full/patches/120-uclibc-nolocale.patch
new file mode 100644 (file)
index 0000000..3e409eb
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/gettext-runtime/intl/localename.c
++++ b/gettext-runtime/intl/localename.c
+@@ -2780,7 +2780,7 @@ gl_locale_name_posix (int category, cons
+ {
+   /* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
+      On some systems this can be done by the 'setlocale' function itself.  */
+-#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL
++#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL && (!defined __UCLIBC__ || defined __UCLIBC_HAS_LOCALE__)
+   return setlocale (category, NULL);
+ #else
+   /* On other systems we ignore what setlocale reports and instead look at the
diff --git a/libs/gettext-full/patches/150-disable_libxml_iconv.patch b/libs/gettext-full/patches/150-disable_libxml_iconv.patch
new file mode 100644 (file)
index 0000000..a8f5a5c
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/gettext-tools/gnulib-lib/libxml/xmlversion.in.h
++++ b/gettext-tools/gnulib-lib/libxml/xmlversion.in.h
+@@ -263,7 +263,7 @@ XMLPUBFUN void XMLCALL xmlCheckVersion(i
+  *
+  * Whether iconv support is available
+  */
+-#if 1
++#if 0
+ #define LIBXML_ICONV_ENABLED
+ #endif
+--- a/gnulib-local/lib/libxml/xmlversion.in.h
++++ b/gnulib-local/lib/libxml/xmlversion.in.h
+@@ -263,7 +263,7 @@ XMLPUBFUN void XMLCALL xmlCheckVersion(i
+  *
+  * Whether iconv support is available
+  */
+-#if 1
++#if 0
+ #define LIBXML_ICONV_ENABLED
+ #endif
diff --git a/libs/gettext/Makefile b/libs/gettext/Makefile
deleted file mode 100644 (file)
index 1b3a50e..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gettext
-PKG_VERSION:=0.18.1.1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/gettext
-PKG_MD5SUM:=3dd55b952826d2b32f51308f2f91aa89
-
-PKG_FIXUP:=libtool
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=0
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libintl
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=GNU Internationalization library
-  URL:=http://www.gnu.org/software/gettext/
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-CONFIGURE_ARGS += \
-       --enable-shared \
-       --enable-static \
-       --disable-rpath \
-       --enable-nls \
-       --disable-java \
-       --disable-native-java \
-       --disable-openmp \
-       --with-included-gettext \
-       --without-libintl-prefix \
-       --without-libexpat-prefix \
-       --without-emacs
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/include/libintl.h $(1)/usr/include/
-
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libintl.{a,so*} $(1)/usr/lib
-
-       $(INSTALL_DIR) $(1)/usr/share/aclocal
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
-endef
-
-define Package/libintl/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libintl.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libintl))
diff --git a/libs/gettext/patches/001-autotools.patch b/libs/gettext/patches/001-autotools.patch
deleted file mode 100644 (file)
index bf44fcb..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/gettext-runtime/man/Makefile.am
-+++ b/gettext-runtime/man/Makefile.am
-@@ -159,8 +159,7 @@ bind_textdomain_codeset.3.html: bind_tex
-       $(MAN2HTML) $(srcdir)/bind_textdomain_codeset.3.in | sed -e '/CreationDate:/d' > t-$@
-       mv t-$@ $@
--install-html-local:
--      $(mkdir_p) $(DESTDIR)$(htmldir)
-+install-html: installdirs-html
-       for file in $(man_HTML); do \
-         if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
-         $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
---- a/gettext-tools/man/Makefile.am
-+++ b/gettext-tools/man/Makefile.am
-@@ -186,8 +186,7 @@ autopoint.1.html: autopoint.1
-       $(MAN2HTML) `if test -f autopoint.1; then echo .; else echo $(srcdir); fi`/autopoint.1 | sed -e '/CreationDate:/d' > t-$@
-       mv t-$@ $@
--install-html-local:
--      $(mkdir_p) $(DESTDIR)$(htmldir)
-+install-html: installdirs-html
-       for file in $(man_HTML); do \
-         if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
-         $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
---- a/gettext-runtime/intl/Makefile.in
-+++ b/gettext-runtime/intl/Makefile.in
-@@ -19,7 +19,7 @@
- PACKAGE = @PACKAGE@
- VERSION = @VERSION@
--SHELL = /bin/sh
-+SHELL = @SHELL@
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
diff --git a/libs/gettext/patches/001-no_examples_and_tests.patch b/libs/gettext/patches/001-no_examples_and_tests.patch
deleted file mode 100644 (file)
index 7cdb389..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/gettext-runtime/Makefile.in
-+++ b/gettext-runtime/Makefile.in
-@@ -208,7 +208,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
- ETAGS = etags
- CTAGS = ctags
- DIST_SUBDIRS = doc intl intl-java intl-csharp gnulib-lib libasprintf \
--      src po man m4 tests
-+      src po man m4
- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
- distdir = $(PACKAGE)-$(VERSION)
- top_distdir = $(distdir)
---- a/gettext-tools/Makefile.in
-+++ b/gettext-tools/Makefile.in
-@@ -1248,7 +1248,7 @@ top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
- AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
- ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
--SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
-+SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4
- # Allow users to use "gnulib-tool --update".
diff --git a/libs/gettext/patches/003-gettext-error_print_progname.patch b/libs/gettext/patches/003-gettext-error_print_progname.patch
deleted file mode 100644 (file)
index 9e84551..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/gettext-tools/libgettextpo/error.h
-+++ b/gettext-tools/libgettextpo/error.h
-@@ -49,7 +49,7 @@ extern void error_at_line (int __status,
- /* If NULL, error will flush stdout, then print on stderr the program
-    name, a colon and a space.  Otherwise, error will call this
-    function without parameters instead.  */
--extern DLL_VARIABLE void (*error_print_progname) (void);
-+void (*error_print_progname) (void);
- /* This variable is incremented each time `error' is called.  */
- extern DLL_VARIABLE unsigned int error_message_count;
diff --git a/libs/gettext/patches/004-gnulib-uclibc-sched_param-def.patch b/libs/gettext/patches/004-gnulib-uclibc-sched_param-def.patch
deleted file mode 100644 (file)
index 051c374..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-uclibc defines __GLIBC__ but it does not expose struct shed_param as much as glibc
-and is not needed too per standard. gnulib attempts to use it but we have to account
-for it because in this case uclibc does not behave like glibc.
-
--Khem
-
---- a/gettext-tools/gnulib-lib/spawn.in.h
-+++ b/gettext-tools/gnulib-lib/spawn.in.h
-@@ -31,7 +31,7 @@
- /* Get definitions of 'struct sched_param' and 'sigset_t'.
-    But avoid namespace pollution on glibc systems.  */
--#ifndef __GLIBC__
-+#if !defined __GLIBC__ || defined __UCLIBC__
- # include <sched.h>
- # include <signal.h>
- #endif
diff --git a/libs/gettext/patches/100-error_progname.patch b/libs/gettext/patches/100-error_progname.patch
deleted file mode 100644 (file)
index f414703..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/gettext-runtime/intl/intl-compat.c
-+++ b/gettext-runtime/intl/intl-compat.c
-@@ -131,3 +131,7 @@ bind_textdomain_codeset (const char *dom
- {
-   return libintl_bind_textdomain_codeset (domainname, codeset);
- }
-+
-+#ifdef __UCLIBC__
-+DLL_EXPORTED void (*error_print_progname)(void) = NULL;
-+#endif
diff --git a/libs/gettext/patches/120-uclibc-nolocale.patch b/libs/gettext/patches/120-uclibc-nolocale.patch
deleted file mode 100644 (file)
index 3e409eb..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/gettext-runtime/intl/localename.c
-+++ b/gettext-runtime/intl/localename.c
-@@ -2780,7 +2780,7 @@ gl_locale_name_posix (int category, cons
- {
-   /* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
-      On some systems this can be done by the 'setlocale' function itself.  */
--#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL
-+#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL && (!defined __UCLIBC__ || defined __UCLIBC_HAS_LOCALE__)
-   return setlocale (category, NULL);
- #else
-   /* On other systems we ignore what setlocale reports and instead look at the
diff --git a/libs/gettext/patches/150-disable_libxml_iconv.patch b/libs/gettext/patches/150-disable_libxml_iconv.patch
deleted file mode 100644 (file)
index a8f5a5c..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/gettext-tools/gnulib-lib/libxml/xmlversion.in.h
-+++ b/gettext-tools/gnulib-lib/libxml/xmlversion.in.h
-@@ -263,7 +263,7 @@ XMLPUBFUN void XMLCALL xmlCheckVersion(i
-  *
-  * Whether iconv support is available
-  */
--#if 1
-+#if 0
- #define LIBXML_ICONV_ENABLED
- #endif
---- a/gnulib-local/lib/libxml/xmlversion.in.h
-+++ b/gnulib-local/lib/libxml/xmlversion.in.h
-@@ -263,7 +263,7 @@ XMLPUBFUN void XMLCALL xmlCheckVersion(i
-  *
-  * Whether iconv support is available
-  */
--#if 1
-+#if 0
- #define LIBXML_ICONV_ENABLED
- #endif