gst-plugins-ugly: update to 0.10.19
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Dec 2012 17:31:28 +0000 (17:31 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Dec 2012 17:31:28 +0000 (17:31 +0000)
Signed-off-by: Andy Leiserson <andy@leiserson.org>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@34522 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/gst-plugins-ugly/Makefile
multimedia/gst-plugins-ugly/patches/001-no_docs.patch
multimedia/gst-plugins-ugly/patches/002-no_tests.patch
multimedia/gst-plugins-ugly/patches/003-no_translations.patch

index 1ebdd7e..d2b819f 100644 (file)
@@ -8,15 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst-plugins-ugly
-PKG_VERSION:=0.10.15
-PKG_RELEASE:=2
+PKG_VERSION:=0.10.19
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/
-PKG_MD5SUM:=21c034a762a5da252f91640e53bfe457
+PKG_MD5SUM:=ba26045c8c8c91f0d48d327ccf53ac0c
 
 PKG_BUILD_DEPENDS:= gstreamer gst-plugins-base liboil
-PKG_CONFIG_DEPENDS:= \
+PKG_CONFIG_Dba26045c8c8c91f0d48d327ccf53ac0cEPENDS:= \
        CONFIG_PACKAGE_gst-mod-asf \
        CONFIG_PACKAGE_gst-mod-lame \
        CONFIG_PACKAGE_gst-mod-mad \
@@ -127,7 +127,7 @@ define GstBuildPlugin
 endef
 
 $(eval $(call GstBuildPlugin,asf,ASF demuxer,audio riff rtp rtsp sdp tag,,))
-$(eval $(call GstBuildPlugin,lame,MP3 encoder (using LAME),,,+lame-lib))
+$(eval $(call GstBuildPlugin,lame,MP3 encoder (using LAME),audio,,+lame-lib))
 $(eval $(call GstBuildPlugin,mad,MP3 decoder (using MAD),audio tag,,+libid3tag +libmad))
 $(eval $(call GstBuildPlugin,mpeg2dec,MPEG decoder,video,,+libmpeg2))
 
index 1810542..8bcb83b 100644 (file)
@@ -4,8 +4,8 @@
  DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
  
  SUBDIRS = \
--      gst-libs gst ext docs m4 tests common po
-+      gst-libs gst ext m4 tests common po
+-      gst-libs gst ext docs m4 tests common pkgconfig po
++      gst-libs gst ext m4 tests common pkgconfig po
  
  # include before EXTRA_DIST for win32 assignment
  include $(top_srcdir)/common/win32.mak
@@ -15,8 +15,8 @@
  top_srcdir = @top_srcdir@
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
  SUBDIRS = \
--      gst-libs gst ext docs m4 tests common po
-+      gst-libs gst ext m4 tests common po
+-      gst-libs gst ext docs m4 tests common pkgconfig po
++      gst-libs gst ext m4 tests common pkgconfig po
  
  
  # the MANIFEST contains all win32 related files that should be disted
index c7eed9d..3a830ac 100644 (file)
@@ -4,8 +4,8 @@
  DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
  
  SUBDIRS = \
--      gst-libs gst ext m4 tests common po
-+      gst-libs gst ext m4 common po
+-      gst-libs gst ext m4 tests common pkgconfig po
++      gst-libs gst ext m4 common pkgconfig po
  
  # include before EXTRA_DIST for win32 assignment
  include $(top_srcdir)/common/win32.mak
@@ -15,8 +15,8 @@
  top_srcdir = @top_srcdir@
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
  SUBDIRS = \
--      gst-libs gst ext m4 tests common po
-+      gst-libs gst ext m4 common po
+-      gst-libs gst ext m4 tests common pkgconfig po
++      gst-libs gst ext m4 common pkgconfig po
  
  
  # the MANIFEST contains all win32 related files that should be disted
index 77015ff..71cc5c5 100644 (file)
@@ -5,6 +5,8 @@
  tests/check/Makefile
  m4/Makefile
 -po/Makefile.in
+ pkgconfig/Makefile
+ pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
  gst-plugins-ugly.spec
  )
  
@@ -14,8 +16,8 @@
  DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
  
  SUBDIRS = \
--      gst-libs gst ext m4 common po
-+      gst-libs gst ext m4 common
+-      gst-libs gst ext m4 common pkgconfig po
++      gst-libs gst ext m4 common pkgconfig
  
  # include before EXTRA_DIST for win32 assignment
  include $(top_srcdir)/common/win32.mak
@@ -25,8 +27,8 @@
  top_srcdir = @top_srcdir@
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
  SUBDIRS = \
--      gst-libs gst ext m4 common po
-+      gst-libs gst ext m4 common
+-      gst-libs gst ext m4 common pkgconfig po
++      gst-libs gst ext m4 common pkgconfig
  
  
  # the MANIFEST contains all win32 related files that should be disted