[packages] libtiff: don't include dev shared lib symlinks in package, bump release...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Jul 2009 13:22:50 +0000 (13:22 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Jul 2009 13:22:50 +0000 (13:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16750 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/tiff/Makefile

index 801e95a..398961b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tiff
 PKG_VERSION:=3.8.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtiff.maptools.org/dl/
@@ -35,13 +35,13 @@ CONFIGURE_ARGS += --without-x
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib,include}
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
 endef
 
 define Package/libtiff/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libtiff))