[patch-team] update wing to 20110329 - Signed off by Roberto Riggio <roberto.riggio...
authordingo <dingo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Dec 2011 13:45:36 +0000 (13:45 +0000)
committerdingo <dingo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Dec 2011 13:45:36 +0000 (13:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29373 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/wing/Makefile
net/wing/files/etc/uci-defaults/wing
net/wing/files/lib/network/wing.sh
net/wing/patches/010-libc-compat.patch [deleted file]

index 47892ca..cb351d7 100644 (file)
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wing
-PKG_VERSION:=20110709
+PKG_VERSION:=20111103
 PKG_RELEASE:=1
-PKG_REV:=6aaea18b8e199781dc600681882cb2648f43ec38
+PKG_REV:=23e6455a1cfe0877334f0d18068a3fb47425b8a4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=git://github.com/rriggio/click.git
@@ -24,9 +24,10 @@ include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
 
 define Package/wing
-       TITLE:=Wireless mesh networking toolkit
        SECTION:=net
        CATEGORY:=Network
+       SUBMENU:=Routing and Redirection
+       TITLE:=Wireless mesh networking toolkit
        MAINTAINER:=Roberto Riggio <roberto.riggio@create-net.org>
        DEPENDS:=+kmod-tun +libpcap +libstdcpp
        URL:=http://www.wing-project.org/
@@ -44,12 +45,16 @@ CONFIGURE_ARGS += \
        --enable-tools=host \
        --enable-userlevel \
        --enable-wifi \
+       --enable-wing \
+       --enable-diffserv \
        --disable-linuxmodule \
        --disable-dynamic-linking \
 
 HOST_CONFIGURE_ARGS += \
        --enable-userlevel \
        --enable-wifi \
+       --enable-wing \
+       --enable-diffserv \
        --disable-linuxmodule \
 
 define Host/Compile
@@ -62,6 +67,7 @@ define Build/Compile
                -f $(PKG_BUILD_DIR)/conf/wing/sample.click \
                -A --all -E Discard -E Print -E PrintWifi -E Strip -E Null \
                -E InfiniteSource -E RatedSource -E EtherEncap -E UDPIPEncap \
+               -E AggregateWingPacketType -E AggregateCounter \
                -E RadiotapEncapHT -E SetTXRateHT \
                -E WINGETTMetric -E WINGETXMetric -E WINGHopCountMetric \
                -E ProbeTXRate -E MadwifiRate -E AutoRateFallback -E Minstrel \
index 9648a9d..f8ba78f 100644 (file)
@@ -1,13 +1,6 @@
 uci delete network.mesh
 uci set network.mesh=interface
 uci set network.mesh.proto=wing
-uci set network.mesh.rc=minstrel
-uci set network.mesh.ls=fcfs
-uci set network.mesh.metric=wcett
-uci set network.mesh.prefix=6
-uci set network.mesh.period=10000
-uci set network.mesh.tau=100000
-uci set network.mesh.debug=false
 
 uci add firewall zone
 uci set firewall.@zone[-1].name="mesh"
index 49e5d3d..d8a5dd0 100644 (file)
@@ -107,7 +107,9 @@ setup_interface_wing() {
        ps | grep /usr/bin/click | grep -v grep | awk '{print $1}' > /var/run/$iface.pid
 
        ifconfig "$iface" "$ipaddr" netmask "$netmask"
-       route add default dev "$iface"
+        route -n | grep -q '^0.0.0.0' || {
+        route add default dev "$iface"
+       }
 
        uci_set_state network $config ifname "$iface"
        uci_set_state network $config ipaddr "$ipaddr"
diff --git a/net/wing/patches/010-libc-compat.patch b/net/wing/patches/010-libc-compat.patch
deleted file mode 100644 (file)
index fa84ac8..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/lib/radiotap.c
-+++ b/lib/radiotap.c
-@@ -16,6 +16,17 @@
- #include <click/radiotap_iter.h>
- #include <click/platform.h>
-+#if !defined(le32toh) || !defined(le16toh)
-+#  if BYTE_ORDER == LITTLE_ENDIAN
-+#    define le32toh(x) (x)
-+#    define le16toh(x) (x)
-+#  else
-+#    include <byteswap.h>
-+#    define le32toh(x) bswap_32(x)
-+#    define le16toh(x) bswap_16(x)
-+#  endif
-+#endif
-+
- /* function prototypes and related defs are in radiotap_iter.h */
- static const struct radiotap_align_size rtap_namespace_sizes[] = {