tiff: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 31 Jul 2014 14:11:00 +0000 (14:11 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 31 Jul 2014 14:11:00 +0000 (14:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41908 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/tiff/Makefile [deleted file]
libs/tiff/patches/001-autoconf-compat.patch [deleted file]

diff --git a/libs/tiff/Makefile b/libs/tiff/Makefile
deleted file mode 100644 (file)
index 148a12e..0000000
+++ /dev/null
@@ -1,104 +0,0 @@
-#
-# Copyright (C) 2006-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=tiff
-PKG_VERSION:=4.0.3
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://download.osgeo.org/libtiff
-PKG_MD5SUM:=051c1068e6a0627f461948c365290410
-
-PKG_FIXUP:=autoreconf
-PKG_REMOVE_FILES:=autogen.sh aclocal.m4
-
-PKG_INSTALL:=1
-
-PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_libtiffxx
-
-include $(INCLUDE_DIR)/uclibc++.mk
-include $(INCLUDE_DIR)/package.mk
-
-define Package/tiff/Default
-  TITLE:=TIFF
-  URL:=http://www.remotesensing.org/libtiff/
-endef
-
-define Package/libtiff
-$(call Package/tiff/Default)
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE+= library
-  DEPENDS:=+zlib +libjpeg
-endef
-
-define Package/libtiffxx
-$(call Package/tiff/Default)
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE+= library(c++ bindings)
-  DEPENDS:=+libtiff $(CXX_DEPENDS)
-endef
-
-define Package/tiff-utils
-$(call Package/tiff/Default)
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE+= utilities
-  DEPENDS:=+libtiff
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               $(if $(CONFIG_PACKAGE_libtiffxx), \
-                       --enable-cxx, \
-                       --disable-cxx \
-               ) \
-               --disable-lzma \
-               --enable-ccitt \
-               --enable-packbits \
-               --enable-lzw \
-               --enable-thunder \
-               --enable-next \
-               --enable-logluv \
-               --enable-mdi \
-               --enable-zlib \
-               --enable-jpeg \
-               --disable-old-jpeg \
-               --disable-jbig \
-               --without-x \
-       )
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/{lib,include}
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
-endef
-
-define Package/libtiff/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiff.so.* $(1)/usr/lib/
-endef
-
-define Package/libtiffxx/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiffxx.so.* $(1)/usr/lib/
-endef
-
-define Package/tiff-utils/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,libtiff))
-$(eval $(call BuildPackage,libtiffxx))
-$(eval $(call BuildPackage,tiff-utils))
diff --git a/libs/tiff/patches/001-autoconf-compat.patch b/libs/tiff/patches/001-autoconf-compat.patch
deleted file mode 100644 (file)
index c7c0dfc..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -25,7 +25,7 @@
- docdir = $(LIBTIFF_DOCDIR)
--AUTOMAKE_OPTIONS = 1.12 dist-zip foreign
-+AUTOMAKE_OPTIONS = dist-zip foreign
- ACLOCAL_AMFLAGS = -I m4
- docfiles = \
-@@ -48,7 +48,7 @@ EXTRA_DIST = \
- dist_doc_DATA = $(docfiles)
--SUBDIRS = port libtiff tools build contrib test man html
-+SUBDIRS = port libtiff tools build contrib
- release:
-       (rm -f $(top_srcdir)/RELEASE-DATE && echo $(LIBTIFF_RELEASE_DATE) > $(top_srcdir)/RELEASE-DATE)
---- a/test/Makefile.am
-+++ b/test/Makefile.am
-@@ -23,7 +23,7 @@
- # Process this file with automake to produce Makefile.in.
--AUTOMAKE_OPTIONS = 1.12 color-tests parallel-tests foreign
-+AUTOMAKE_OPTIONS = color-tests parallel-tests foreign
- LIBTIFF = $(top_builddir)/libtiff/libtiff.la